Closed Bug 1564200 Opened 4 months ago Closed 4 months ago

/system/bin/sh: cat: sys/class/thermal/thermal_zone0/temp: No such file or directory running Raptor against x86 emulator

Categories

(Testing :: Raptor, defect, P2)

Version 3
defect

Tracking

(firefox-esr60 unaffected, firefox-esr68 unaffected, firefox68 unaffected, firefox69 fixed, firefox70 fixed)

RESOLVED FIXED
mozilla70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 --- fixed
firefox70 --- fixed

People

(Reporter: nalexander, Assigned: marauder)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Bug 1561699 breaks running Raptor locally against the x86 emulator, which is critical for fast development.

17:55:13    ERROR -  Traceback (most recent call last):
17:55:13     INFO -    File "/Users/nalexander/Mozilla/gecko/testing/raptor/raptor/raptor.py", line 1179, in <module>
17:55:13     INFO -      main()
17:55:13     INFO -    File "/Users/nalexander/Mozilla/gecko/testing/raptor/raptor/raptor.py", line 1147, in main
17:55:13     INFO -      success = raptor.run_tests(raptor_test_list, raptor_test_names)
17:55:13     INFO -    File "/Users/nalexander/Mozilla/gecko/testing/raptor/raptor/raptor.py", line 899, in run_tests
17:55:13     INFO -      return super(RaptorAndroid, self).run_tests(tests, test_names)
17:55:13     INFO -    File "/Users/nalexander/Mozilla/gecko/testing/raptor/raptor/raptor.py", line 170, in run_tests
17:55:13     INFO -      self.run_test(test, timeout=int(test.get('page_timeout')))
17:55:13     INFO -    File "/Users/nalexander/Mozilla/gecko/testing/raptor/raptor/raptor.py", line 929, in run_test
17:55:13     INFO -      self.__run_test_cold(test, timeout)
17:55:13     INFO -    File "/Users/nalexander/Mozilla/gecko/testing/raptor/raptor/raptor.py", line 1008, in __run_test_cold
17:55:13     INFO -      self.log_android_device_temperature()
17:55:13     INFO -    File "/Users/nalexander/Mozilla/gecko/testing/raptor/raptor/raptor.py", line 828, in log_android_device_temperature
17:55:13     INFO -      thermal_zone0 = float(self.device.shell_output('cat sys/class/thermal/thermal_zone0/temp'))
17:55:13     INFO -    File "/Users/nalexander/Mozilla/gecko/testing/mozbase/mozdevice/mozdevice/adb.py", line 1486, in shell_output
17:55:13     INFO -      raise ADBProcessError(adb_process)
17:55:13     INFO -  mozdevice.adb.ADBProcessError: args: adb wait-for-device shell cat sys/class/thermal/thermal_zone0/temp; echo adb_returncode=$?, exitcode: 1, stdout: adb_returncode=1
17:55:13     INFO -  /system/bin/sh: cat: sys/class/thermal/thermal_zone0/temp: No such file or directory
17:55:13    ERROR - Return code: 1

I see:

nalexander@roboto ~/M/gecko> adb shell find /sys/class/thermal
/sys/class/thermal
/sys/class/thermal/cooling_device0
/sys/class/thermal/cooling_device1
/sys/class/thermal/cooling_device2
/sys/class/thermal/cooling_device3

Presumably, this can (and maybe even does?) vary by device. Can we make this fail gracefully on the emulator?

Priority: -- → P2

I also see a failure on my local pixel2 where it has a kernel bug which causes an ADBError due to an I/O error attempting to read that file. Making this non-fatal would be nice since it would mean I would still be able to run raptor even if there is not an android update available to fix the issue.

See bug 1566132 comment 9 where walleye-pq3a.190705.001 continues to fail to read these values.

See Also: → 1566132

Handle the exception ADBProcessError raised by
thermal_zone0 = self.device.shell_output('cat sys/class/thermal/thermal_zone0/temp')
on the emulator

Pushed by mraiciof@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/91aafa351313
No such file or directory running Raptor against x86 emulator r=perftest-reviewers,Bebe
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
Assignee: nobody → marian.raiciof

With my local p2 updated to the latest Android 9 I'm getting

06:28:06     INFO -  raptor-main Warning: Unexpected error: ADBProcessError - args: adb wait-for-device shell cat sys/class/thermal/thermal_zone0/temp; echo adb_returncode=$?, exitcode: 1, stdout: cat: sys/class/thermal/thermal_zone0/temp: I/O error

This won't classify the job as a failure will it?

(In reply to Bob Clary [:bc:] from comment #8)

With my local p2 updated to the latest Android 9 I'm getting

06:28:06     INFO -  raptor-main Warning: Unexpected error: ADBProcessError - args: adb wait-for-device shell cat sys/class/thermal/thermal_zone0/temp; echo adb_returncode=$?, exitcode: 1, stdout: cat: sys/class/thermal/thermal_zone0/temp: I/O error

This won't classify the job as a failure will it?

I don't believe so as we're catching the exception and logging a warning, so the exit code shouldn't be affected.

You need to log in before you can comment on or make changes to this bug.