Closed Bug 1564228 Opened 2 years ago Closed 2 years ago

The placeholder text doesn't go away when using the new password generation UI

Categories

(Toolkit :: Password Manager, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1198363

People

(Reporter: ehsan.akhgari, Unassigned)

References

(Regression)

Details

Attachments

(1 file)

Attached image Screenshot

STR:

  1. Set signon.generation.available and signon.generation.enabled to true.
  2. Go to www.facebook.com.
  3. Right click on the New Password field, from the context menu choose Fill Password > Use a Suggested Password.

We autogenerate the password string, but the placeholder text for the input control doesn't get cleared out. See the screenshot.

Hello Sam, could you please look into this?

Flags: needinfo?(sfoster)
Priority: -- → P1

I'll move to the password manager component while we investigate, I'm not sure if this is something we are/are not doing or an editor bug.
Clearing priority for now so it goes into our triage queue.

Component: Editor → Password Manager
Flags: needinfo?(sfoster)
Priority: P1 → --
Product: Core → Toolkit

It may be caused by the way you're setting the value on the editor object. The placeholder value gets cleared on a number of different code paths, but I believe if you use something that isn't exposed to the web (e.g. the .value setter) then it is possible to end up in this state...

Looks like that it uses MozEditableElement.setUserInput() (this is right approach). It's into same path as setting value with additional flag. And HTMLInputElement handles palceholder at here. So, it should work with placeholder attribute.

However, Facebook uses their own placeholder text. Check div[class=placeholder][area-hidden=true]. We dispatch input event even when we use SetUserInput() (not using suppressInputEventDispatching.Init()).

So, I guess that Facebook does not listen to input event to show/hide the their own placeholder.

Right, this is a known issue with facebook.com that also affected Form Autofill on other sites (bug 1395928). See https://github.com/whatwg/html/issues/3016 for the HTML spec issue that needs attention.

We could also tell Facebook to fix this on their side but it won't help the similar issues on sears.com and other sites.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
See Also: → 1395928
Duplicate of bug: 1198363
You need to log in before you can comment on or make changes to this bug.