Closed Bug 1564248 Opened 1 year ago Closed 5 months ago

Double check if the contentblocking.exceptions probe was really needed

Categories

(Firefox :: Protections UI, task, P1)

task

Tracking

()

RESOLVED FIXED
Firefox 71
Tracking Status
firefox70 --- fixed
firefox71 --- fixed

People

(Reporter: ehsan, Assigned: johannh)

References

Details

Attachments

(2 files)

In bug 1564241 we had to quickly remove the probe as an emergency fix to re-open mozilla-central, but we should probably double check to ensure that the probe is indeed unneeded as due diligence.

Johann, can you please check this? Thanks!

Flags: needinfo?(jhofmann)

Cindy, Pdol, this is a probe that measures the amount of content blocking exceptions a user has at startup. Would you like to keep measuring this for 70 and beyond or can we sunset it?

Thanks!

Flags: needinfo?(pdolanjski)
Flags: needinfo?(jhofmann)
Flags: needinfo?(chsiang)

sorry for getting back to this late. is this the probe to tell us how many users have ETP on vs. off?
If so, I'd like to keep measuring this for 70 and beyond (we can set it to expire at 75 to be consistent with many other probes related to skyline).

Flags: needinfo?(chsiang)
Flags: needinfo?(pdolanjski)

(In reply to chsiang from comment #2)

sorry for getting back to this late. is this the probe to tell us how many users have ETP on vs. off?

No, this measures how many sites the user has disabled content blocking on.

And in order to set expectations, this has been removed from Firefox 70, and unless there isn't swift action taken to explain the data collection needs, if any, for a new probe as a replacement in a few weeks, Firefox 70 will be released without it.

Let's try and get this into 70. We'll see if there's still enough time :)

Assignee: nobody → jhofmann
Status: NEW → ASSIGNED
Priority: -- → P1
Attached file request.md
Attachment #9095159 - Flags: data-review?(chutten)
Comment on attachment 9095159 [details]
request.md

Load balancing to Teon.
Attachment #9095159 - Flags: data-review?(chutten) → data-review?(teon)
Comment on attachment 9095159 [details]
request.md

DATA COLLECTION REVIEW RESPONSE:

    Is there or will there be documentation that describes the schema for the ultimate data set available publicly, complete and accurate?

Yes. This collection is Telemetry so is documented in its definitions file [Scalars.yaml](https://hg.mozilla.org/mozilla-central/file/tip/toolkit/components/telemetry/Scalars.yaml) and the [Probe Dictionary](https://telemetry.mozilla.org/probe-dictionary/).

    Is there a control mechanism that allows the user to turn the data collection on and off?

Yes. This collection is Telemetry so can be controlled through Firefox's Preferences.

    If the request is for permanent data collection, is there someone who will monitor the data over time?

No. This collection will expire in Fx 75.

    Using the category system of data types on the Mozilla wiki, what collection type of data do the requested measurements fall under?

Category 2, Interaction.

    Is the data collection request for default-on or default-off?

Default on for all channels.

    Does the instrumentation include the addition of any new identifiers?

No.

    Is the data collection covered by the existing Firefox privacy notice?

Yes.

    Does there need to be a check-in in the future to determine whether to renew the data?

Yes. :johannh is responsible for renewing or removing the collection before it expires in Fx75.

---
Result: datareview
Attachment #9095159 - Flags: data-review?(teon) → data-review+
Pushed by jhofmann@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/89c94db8a4be
Re-add contentblocking.exceptions and extend the measurement to 75. r=Ehsan
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71

Comment on attachment 9095160 [details]
Bug 1564248 - Re-add contentblocking.exceptions and extend the measurement to 75. r=ehsan

Beta/Release Uplift Approval Request

  • User impact if declined: Removed a telemetry probe that we actually wanted to keep.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Re-adding back a very simple telemetry probe that had previously existed for a long time.
  • String changes made/needed: None
Attachment #9095160 - Flags: approval-mozilla-beta?

Comment on attachment 9095160 [details]
Bug 1564248 - Re-add contentblocking.exceptions and extend the measurement to 75. r=ehsan

OK for uplift for beta 11.

Attachment #9095160 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Duplicate of this bug: 1607499
You need to log in before you can comment on or make changes to this bug.