Closed Bug 1564330 Opened 3 months ago Closed 3 months ago

Update to tzdata2019b

Categories

(Core :: JavaScript: Internationalization API, task)

task
Not set

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox-esr60 --- fixed
firefox-esr68 --- fixed
firefox69 --- fixed
firefox70 --- fixed

People

(Reporter: anba, Assigned: anba)

References

Details

Attachments

(4 files)

tzdata 2019b was released recently.

Release notes:

https://mm.icann.org/pipermail/tz-announce/2019-July/000056.html

Pushed by cbrindusan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/633fc7b52221
Update tzdata in ICU data files to 2019b. r=jwalden

Keywords: checkin-needed
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70

Shouldn't this one be uplifted to Firefox69 and 68ESR?

(In reply to Alexandre Folle de Menezes from comment #9)

Shouldn't this one be uplifted to Firefox69 and 68ESR?

Yes. The patches for Beta and both ESR branches are already present (see comment #5), I normally just wait a few days before requesting uplifts to make sure no unexpected breakage did occur.

Comment on attachment 9077055 [details]
Bug 1564330: Update tzdata in ICU data files to 2019b. r=jwalden!

Beta/Release Uplift Approval Request

  • User impact if declined: Wrong time zone data when calling standard Date and Intl.DateTimeFormat methods.

Based on the release notes for tzdata 2019b https://mm.icann.org/pipermail/tz-announce/2019-July/000056.html, the update is of special interest for users in:

  • Brazil, which cancelled DST and now stays on standard time indefinitely.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): It only updates time zone data files.
  • String changes made/needed: None
Attachment #9077055 - Flags: approval-mozilla-beta?

Comment on attachment 9077056 [details]
Bug 1564330: Update tzdata in ICU data files to 2019b. r=jwalden!

ESR Uplift Approval Request

  • If this is not a sec:{high,crit} bug, please state case for ESR consideration: See Beta uplift request.
  • User impact if declined: See Beta uplift request.
  • Fix Landed on Version: 70
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): See Beta uplift request.
  • String or UUID changes made by this patch: None
Attachment #9077056 - Flags: approval-mozilla-esr68?

Comment on attachment 9077058 [details]
Bug 1564330: Update tzdata in ICU data files to 2019b. r=jwalden!

ESR Uplift Approval Request

  • If this is not a sec:{high,crit} bug, please state case for ESR consideration: See Beta uplift request.
  • User impact if declined: See Beta uplift request.
  • Fix Landed on Version: 70
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): See Beta uplift request.
  • String or UUID changes made by this patch: None
Attachment #9077058 - Flags: approval-mozilla-esr60?

Comment on attachment 9077055 [details]
Bug 1564330: Update tzdata in ICU data files to 2019b. r=jwalden!

Updates our timezone data. Approved for 69.0b6, 68.1esr, and 60.9esr.

Attachment #9077055 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #9077056 - Flags: approval-mozilla-esr68? → approval-mozilla-esr68+
Attachment #9077058 - Flags: approval-mozilla-esr60? → approval-mozilla-esr60+
Duplicate of this bug: 1574476
You need to log in before you can comment on or make changes to this bug.