Closed Bug 1564337 Opened 1 year ago Closed 1 year ago

Consider renaming BaselineCompiler.cpp/h to BaselineCodeGen.cpp/h

Categories

(Core :: JavaScript Engine: JIT, task, P2)

task

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox70 --- fixed

People

(Reporter: jandem, Assigned: jandem)

References

Details

Attachments

(1 file)

Now that we have both JIT and interpreter code there, using the name of the shared base class, BaselineCodeGen<>, might make more sense.

Priority: -- → P2

+1. I think this is a good idea.

Here is summary of what is in BaselineCompiler.cpp right now if anyone has thoughts on the organization of files.

BaselineCodeGen<Handler>

BaselineCompiler
BaselineCompilerHandler
BaselineCompilerCodeGen

BaselineInterpreterGenerator
BaselineInterpreterHandler
BaselineInterpreterCodeGen

JitRuntime::generateDebugTrapHandler

static ComputeAddressOfLocal
static EmitCallFrameIsDebuggeeCheck
static LoadAliasedVarEnv
static LoadBaselineScriptResumeEntries
static LoadInlineValueOperand
static LoadInt32Operand
static LoadInt32OperandSignExtendToPtr
static LoadInt8Operand
static LoadUint16Operand
static LoadUint24Operand
static LoadUint8Operand
static MaybeIncrementCodeCoverageCounter
static LoadBytecodePC
static GetScriptGCThing

constexpr InterpreterPCRegAtDispatch
constexpr HasInterpreterPCReg
constexpr TableSwitchOpFirstResumeIndexOffset
constexpr TableSwitchOpHighOffset
constexpr TableSwitchOpLowOffset

Now that BaselineInterpreterGenerator is also defined there, it's nicer to use the
name of the shared base class.

Pushed by jdemooij@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1487d7146b50
Rename BaselineCompiler.cpp/h to BaselineCodeGen.cpp/h. r=djvj
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
You need to log in before you can comment on or make changes to this bug.