Closed Bug 1564344 Opened 3 years ago Closed 3 years ago

Intermittent TV tier 2 image/test/unit/test_private_channel.js | xpcshell return code: 0

Categories

(Core :: ImageLib, defect, P5)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1564236

People

(Reporter: intermittent-bug-filer, Assigned: gbrown)

References

(Regression)

Details

(Keywords: intermittent-failure, regression)

Filed by: ncsoregi [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=255419582&repo=mozilla-inbound
Full log: https://queue.taskcluster.net/v1/task/J-ZFcaNxTBaN3MGrDP0WnA/runs/0/artifacts/public/logs/live_backing.log
Reftest URL: https://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml#logurl=https://queue.taskcluster.net/v1/task/J-ZFcaNxTBaN3MGrDP0WnA/runs/0/artifacts/public/logs/live_backing.log&only_show_unexpected=1


[task 2019-07-09T05:05:27.428Z] 05:05:27 INFO - TEST-START | image/test/unit/test_private_channel.js
[task 2019-07-09T05:05:27.935Z] 05:05:27 WARNING - TEST-UNEXPECTED-FAIL | image/test/unit/test_private_channel.js | xpcshell return code: 0
[task 2019-07-09T05:05:27.935Z] 05:05:27 INFO - TEST-INFO took 507ms
[task 2019-07-09T05:05:27.935Z] 05:05:27 INFO - >>>>>>>
[task 2019-07-09T05:05:27.935Z] 05:05:27 INFO - image/test/unit/test_private_channel.js | xpcw: cd /sdcard/tests/xpc/image/test/unit
[task 2019-07-09T05:05:27.937Z] 05:05:27 INFO - image/test/unit/test_private_channel.js | xpcw: xpcshell -r /sdcard/tests/xpc/c/httpd.manifest --greomni /data/local/xpcb/target.apk -m -s -e const _HEAD_JS_PATH = "/sdcard/tests/xpc/head.js"; -e const _MOZINFO_JS_PATH = "/sdcard/tests/xpc/p/mozinfo.json"; -e const _PREFS_FILE = "/sdcard/tests/xpc/user.js"; -e const _TESTING_MODULES_DIR = "/sdcard/tests/xpc/m"; -f /sdcard/tests/xpc/head.js -e const _HEAD_FILES = []; -e const _JSDEBUGGER_PORT = 0; -e const _TEST_FILE = ["test_private_channel.js"]; -e const _TEST_NAME = "image/test/unit/test_private_channel.js"; -e _execute_test(); quit(0);
[task 2019-07-09T05:05:27.937Z] 05:05:27 INFO - image/test/unit/test_private_channel.js | /data/local/xpcb/xpcw[18]: cd: /sdcard/tests/xpc/image/test/unit: No such file or directory
[task 2019-07-09T05:05:27.937Z] 05:05:27 INFO - Error: cannot open file 'test_private_channel.js' for reading at /sdcard/tests/xpc/head.js:681
[task 2019-07-09T05:05:27.937Z] 05:05:27 INFO - load_file@/sdcard/tests/xpc/head.js:681:7
[task 2019-07-09T05:05:27.938Z] 05:05:27 INFO - _load_files@/sdcard/tests/xpc/head.js:693:10
[task 2019-07-09T05:05:27.938Z] 05:05:27 INFO - _execute_test@/sdcard/tests/xpc/head.js:544:3
[task 2019-07-09T05:05:27.938Z] 05:05:27 INFO - @-e:1:1
[task 2019-07-09T05:05:27.938Z] 05:05:27 INFO - (xpcshell/head.js) | test MAIN run_test pending (1)
[task 2019-07-09T05:05:27.938Z] 05:05:27 INFO - (xpcshell/head.js) | test run_next_test 0 pending (2)
[task 2019-07-09T05:05:27.938Z] 05:05:27 INFO - (xpcshell/head.js) | test MAIN run_test finished (2)
[task 2019-07-09T05:05:27.938Z] 05:05:27 INFO - running event loop
[task 2019-07-09T05:05:27.939Z] 05:05:27 INFO - (xpcshell/head.js) | test run_next_test 0 finished (1)
[task 2019-07-09T05:05:27.939Z] 05:05:27 INFO - exiting test
[task 2019-07-09T05:05:27.939Z] 05:05:27 INFO - image/test/unit/test_private_channel.js | JavaScript error: resource://testing-common/PromiseTestUtils.jsm, line 112: uncaught exception: Object
[task 2019-07-09T05:05:27.939Z] 05:05:27 INFO - <<<<<<<

Regressed by: 1560455
Type: -- → defect

Missing files on device, just like...

Assignee: nobody → gbrown
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1564236
Has Regression Range: --- → yes
You need to log in before you can comment on or make changes to this bug.