Closed Bug 1564345 Opened 3 years ago Closed 7 months ago

Intermittent Last test finished | application crashed [@ mozilla::ipc::LogicError(char const*)]

Categories

(Core :: IPC, defect, P5)

defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: intermittent-bug-filer, Unassigned)

Details

(Keywords: crash, intermittent-failure, regression)

Crash Data

Filed by: ncsoregi [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=255423539&repo=mozilla-inbound
Full log: https://queue.taskcluster.net/v1/task/RRDL_0sfSAOjRmOdayEfQw/runs/0/artifacts/public/logs/live_backing.log
Reftest URL: https://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml#logurl=https://queue.taskcluster.net/v1/task/RRDL_0sfSAOjRmOdayEfQw/runs/0/artifacts/public/logs/live_backing.log&only_show_unexpected=1


06:20:24 INFO - PROCESS-CRASH | Last test finished | application crashed [@ mozilla::ipc::LogicError(char const*)]
06:20:24 INFO - Crash dump filename: /var/folders/vr/w_fb3qrs6nv229ms2fw023sh000017/T/tmp57WCr4.mozrunner/minidumps/B194BA04-EB8D-452E-BC12-3F9FB831F661.dmp
06:20:24 INFO - Operating system: Mac OS X
06:20:24 INFO - 10.14.5 18F132
06:20:24 INFO - CPU: amd64
06:20:24 INFO - family 6 model 69 stepping 1
06:20:24 INFO - 4 CPUs
06:20:24 INFO -
06:20:24 INFO - GPU: UNKNOWN
06:20:24 INFO -
06:20:24 INFO - Crash reason: EXC_BAD_ACCESS / KERN_INVALID_ADDRESS
06:20:24 INFO - Crash address: 0x0
06:20:24 INFO - Process uptime: 128 seconds
06:20:24 INFO -
06:20:24 INFO - Thread 0 (crashed)
06:20:24 INFO - 0 XUL!mozilla::ipc::LogicError(char const*) [ProtocolUtils.cpp:d178951a5dcb9998b128927cb21c6021b39b078e : 269 + 0xe]
06:20:24 INFO - rax = 0x0000000100558de0 rdx = 0x0000000000000001
06:20:24 INFO - rcx = 0x00000000e5e5e5e3 rbx = 0x000000011d524008
06:20:24 INFO - rsi = 0x000000007f124068 rdi = 0x000000010d094536
06:20:24 INFO - rbp = 0x00007ffeef708890 rsp = 0x00007ffeef708890
06:20:24 INFO - r8 = 0x0000000100600170 r9 = 0x00000000ffffffff
06:20:24 INFO - r10 = 0x0000000151600060 r11 = 0x0000000000000001
06:20:24 INFO - r12 = 0x0000000000033bc0 r13 = 0x0000000100558df0
06:20:24 INFO - r14 = 0x0000000114cd0920 r15 = 0x0000000114cd09b0
06:20:24 INFO - rip = 0x0000000107d95dfe
06:20:24 INFO - Found by: given as instruction pointer in context
06:20:24 INFO - 1 XUL!mozilla::gfx::GPUProcessManager::~GPUProcessManager() [GPUProcessManager.cpp:d178951a5dcb9998b128927cb21c6021b39b078e : 104 + 0x4f]
06:20:24 INFO - rbp = 0x00007ffeef7088d0 rsp = 0x00007ffeef7088a0
06:20:24 INFO - rip = 0x000000010899811e
06:20:24 INFO - Found by: previous frame's frame pointer
06:20:24 INFO - 2 XUL!gfxPlatform::Shutdown() [gfxPlatform.cpp:d178951a5dcb9998b128927cb21c6021b39b078e : 1247 + 0x1f]
06:20:24 INFO - rbp = 0x00007ffeef708930 rsp = 0x00007ffeef7088e0
06:20:24 INFO - rip = 0x0000000108911372
06:20:24 INFO - Found by: previous frame's frame pointer
06:20:24 INFO - 3 XUL!nsLayoutModuleDtor() [nsLayoutModule.cpp:d178951a5dcb9998b128927cb21c6021b39b078e : 266 + 0x5]
06:20:24 INFO - rbp = 0x00007ffeef708950 rsp = 0x00007ffeef708940
06:20:24 INFO - rip = 0x000000010b010e57
06:20:24 INFO - Found by: previous frame's frame pointer
06:20:24 INFO - 4 XUL!nsComponentManagerImpl::Shutdown() [nsComponentManager.cpp:d178951a5dcb9998b128927cb21c6021b39b078e : 945 + 0x5]
06:20:24 INFO - rbp = 0x00007ffeef7089a0 rsp = 0x00007ffeef708960
06:20:24 INFO - rip = 0x0000000107637aff
06:20:24 INFO - Found by: previous frame's frame pointer
06:20:24 INFO - 5 XUL!mozilla::ShutdownXPCOM(nsIServiceManager*) [XPCOMInit.cpp:d178951a5dcb9998b128927cb21c6021b39b078e : 724 + 0x5]
06:20:24 INFO - rbp = 0x00007ffeef708a10 rsp = 0x00007ffeef7089b0
06:20:24 INFO - rip = 0x000000010767dadf
06:20:24 INFO - Found by: previous frame's frame pointer
06:20:24 INFO - 6 XUL!ScopedXPCOMStartup::~ScopedXPCOMStartup() [nsAppRunner.cpp:d178951a5dcb9998b128927cb21c6021b39b078e : 1248 + 0x8]
06:20:24 INFO - rbp = 0x00007ffeef708a70 rsp = 0x00007ffeef708a20
06:20:24 INFO - rip = 0x000000010c06a8ca
06:20:24 INFO - Found by: previous frame's frame pointer
06:20:24 INFO - 7 XUL!XREMain::XRE_main(int, char**, mozilla::BootstrapConfig const&) [nsAppRunner.cpp:d178951a5dcb9998b128927cb21c6021b39b078e : 4798 + 0x19]
06:20:24 INFO - rbp = 0x00007ffeef708bf0 rsp = 0x00007ffeef708a80
06:20:24 INFO - rip = 0x000000010c0750c9
06:20:24 INFO - Found by: previous frame's frame pointer
06:20:24 INFO - 8 XUL!mozilla::BootstrapImpl::XRE_main(int, char**, mozilla::BootstrapConfig const&) [Bootstrap.cpp:d178951a5dcb9998b128927cb21c6021b39b078e : 45 + 0xf1]
06:20:24 INFO - rbp = 0x00007ffeef708d30 rsp = 0x00007ffeef708c00
06:20:24 INFO - rip = 0x000000010c080c0d
06:20:24 INFO - Found by: previous frame's frame pointer
06:20:24 INFO - 9 firefox!main [nsBrowserApp.cpp:d178951a5dcb9998b128927cb21c6021b39b078e : 295 + 0x1c5]
06:20:24 INFO - rbp = 0x00007ffeef709190 rsp = 0x00007ffeef708d40
06:20:24 INFO - rip = 0x00000001004f7163
06:20:24 INFO - Found by: previous frame's frame pointer
06:20:24 INFO - 10 libdyld.dylib!start + 0x1
06:20:24 INFO - rbp = 0x00007ffeef7091a0 rsp = 0x00007ffeef7091a0
06:20:24 INFO - rip = 0x00007fff594c13d5
06:20:24 INFO - Found by: previous frame's frame pointer
06:20:24 INFO -

last test run: dom/tests/browser/browser_localStorage_snapshotting_e10s.js

Regressed by: 1560455

@nataliaCs: why was this regressed by 1560455?

Flags: needinfo?(ncsoregi)

This is the push: https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&selectedJob=255423539&revision=d178951a5dcb9998b128927cb21c6021b39b078e
The failure also contains TinderboxPrint: Per-test run of .../browser_localStorage_snapshotting_e10s.js<br/>: FAILURE , and the last test before the crash occurred was browser_localStorage_snapshotting_e10s.js.
Since this file ^^ occurs as changed within https://hg.mozilla.org/mozilla-central/rev/19acdaa55d35 , I thought maybe it has something to do with it.
I will clean up the regressed by field.
Thank you.

No longer regressed by: 1560455
Flags: needinfo?(ncsoregi)
Component: DOM: Core & HTML → IPC

Maybe I'm missing something, but there doesn't seem to be any indication in the crash report of what specifically caused the error (or what the string passed to MOZ_CRASH_UNSAFE was). I was going to see if I could use addr2line -i to recover what's missing from the minidump stack walk due to inlining, but there's no crashreporter-symbols-full artifact for the build.

This can be revisited if/when there's a crash report with more actionable information.

Priority: -- → P5

Closing this as resolved:worksforme since there were no crashes in the last 6 months for this signature.

Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.