Closed Bug 1564425 Opened 7 months ago Closed 5 months ago

addtest failed with TypeError

Categories

(Testing :: General, defect, P3)

x86_64
Linux
defect

Tracking

(firefox70 fixed)

RESOLVED FIXED
mozilla70
Tracking Status
firefox70 --- fixed

People

(Reporter: sg, Assigned: jgraham)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Running

/mach addtest dom/indexedDB/test/unit/test_cursor_large_iteration.js --suite mochitest-plain

failed with

TypeError: expected a string or other character buffer object

File "/home/osboxes/work/mozilla-unified/testing/mach_commands.py", line 203, in addtest
f.write(template)

Product: Firefox Build System → Testing

Maybe regressed by bug 1543244?

Priority: -- → P3
See Also: → 1543244

The problem is that the tool doesn't know how to create a .js mochitest; it expects the test to have a .html extension. I don't know if we actually support js-only mochitests, but in any case the error handling could be better here.

Ensure that if we try to create a mochitest of unsupported file type we return a
useful error

Pushed by james@hoppipolla.co.uk:
https://hg.mozilla.org/integration/autoland/rev/9c6999666815
Improve error handling of mach addtest, r=bgrins
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
You need to log in before you can comment on or make changes to this bug.