Closed Bug 1564647 Opened 5 months ago Closed 5 months ago

rsdparsa fails to build with rust 1.37

Categories

(Core :: WebRTC: Signaling, task, P2)

70 Branch
task

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox70 --- fixed

People

(Reporter: erahm, Assigned: erahm)

References

Details

Attachments

(1 file)

sdp/rsdparsa/ fails with several ... range patterns are deprecated errors when building with rust 1.37.

Thanks Eric, this has been fixed already upstream. And Nico is actively working on landing a bigger patchset. My assumption is that we update from upstream after Nico's big patch. Landing this patch would probably result in merge conflicts. Any thoughts Nico?

@erahm: how urgent is the update to 1.37 for m-c?

Flags: needinfo?(na-g)

(In reply to Nils Ohlmeier [:drno] from comment #2)

Thanks Eric, this has been fixed already upstream. And Nico is actively working on landing a bigger patchset. My assumption is that we update from upstream after Nico's big patch. Landing this patch would probably result in merge conflicts. Any thoughts Nico?

@erahm: how urgent is the update to 1.37 for m-c?

Oh, I completely missed that we grab this from upstream! I'm fine waiting a bit, but we'd like to get the rust update done by next week if possible so that we get a fair amount of time to test out enabling rust PGO on nightly before 1.37 goes to release.

Nils, I don't mind going ahead and landing Eric's patch now to get it more time to bake.

Flags: needinfo?(na-g)
Assignee: nobody → erahm
Priority: -- → P2
Version: 40 Branch → 70 Branch
Pushed by erahm@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/78deb0f23903
Fix sdp `...` range patterns are deprecated errors. r!drno r=drno,ng
Duplicate of this bug: 1559644
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
You need to log in before you can comment on or make changes to this bug.