Closed Bug 1564851 Opened 5 months ago Closed 4 months ago

Turn off gfx.webrender.all.qualified before shipping Firefox 69

Categories

(Core :: Graphics: WebRender, task, P1)

Other Branch
task

Tracking

()

VERIFIED FIXED
Tracking Status
firefox68 --- unaffected
firefox69 + verified
firefox70 --- unaffected

People

(Reporter: kats, Assigned: jrmuizel)

References

Details

Attachments

(1 file, 1 obsolete file)

[Tracking Requested - why for this release]: So that we don't forget to land this before releasing 69.

For Firefox 69, we are planning to do a gradual rollout of Firefox to the intel-mvp population. The way we will do this is to turn off the gfx.webrender.all.qualified pref just before releasing 69, and then turn it on gradually for users via Normandy. This is similar to what we did in bug 1541489 for Firefox 67.

Patches in bug 1550023 ensure that existing populations that have WR in release (the nvidia and AMD populations) will have WR turned on unconditionally, so turning off gfx.webrender.all.qualified will not affect them. It should only affect the intel-mvp population.

Here's the patch for 69.

Assignee: kats → jmuizelaar

Due to concerns about Bug 1556634 we are not going to ship our target (low res desktop machines with intel graphics cards) with 69 and will move this out to 70.

Jessie, in light of comment 2, can you please confirm what if anything needs to happen for WebRender rollout in 69? Does this patch still need to land?

Flags: needinfo?(jbonisteel)

Yes, we will want to disable WR still - will land this next week.

Flags: needinfo?(jbonisteel) → needinfo?(jmuizelaar)
Pushed by jmuizelaar@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/025d1028313e
Disable gfx.webrender.all.qualified by default.

This wasn't actually supposed to land on central...

Comment on attachment 9088148 [details]
Bug 1564851 - Disable gfx.webrender.all.qualified by default.

Beta/Release Uplift Approval Request

  • User impact if declined: WebRender will ship where we don't want it to.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky):
  • String changes made/needed:
Flags: needinfo?(jmuizelaar)
Attachment #9088148 - Flags: approval-mozilla-beta?
Attachment #9077094 - Flags: approval-mozilla-beta?

Backed out changeset 025d1028313e (bug 1564851) wasn't ment to land on autoland

Backout:
https://hg.mozilla.org/integration/autoland/rev/25a41615b0cea3f7f02f729bbda60ff353ec2755

Attachment #9077094 - Attachment is obsolete: true
Attachment #9077094 - Flags: approval-mozilla-beta?

Comment on attachment 9088148 [details]
Bug 1564851 - Disable gfx.webrender.all.qualified by default.

Disables WebRender per the rollout plan. Approved for 69.0rc1.

Attachment #9088148 - Flags: approval-mozilla-beta? → approval-mozilla-release+
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

Verified - fixed on the latest Firefox 69.0 (Build ID: 20190827005903) on Windows 10 x64 with Intel integrated graphics card.
Webrender is disabled by default.

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.