Closed Bug 1564877 Opened 4 months ago Closed 4 months ago

The Avatar picture is not restore to the default one, after you are sign out from your firefox account

Categories

(Firefox :: Firefox Accounts, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox67 --- unaffected
firefox68 --- unaffected
firefox69 + verified
firefox70 + verified

People

(Reporter: Ovidiu, Assigned: vbudhram)

References

(Regression)

Details

(Keywords: regression, Whiteboard: [FxA])

Attachments

(1 file, 1 obsolete file)

Affected versions

  • Beta 69.0b3 and Nightly 70.0a1(2019-07-09)
    This issue is not reproducible on FF Release 68.

Affected platforms

  • Tested on Mac OS X 10.14 and Windows 10

Steps to reproduce

Prerequisites: You need to have a picture set to your sync account.

  1. Log into your sync account. - the avatar picture is displayed.
  2. Log out from your sync account.

Expected result

  • The avatar icon is set to default.

Actual result

  • The avatar icon is not set to default, your avatar picture is still displayed.

Regression range
Last good revision: 01f72d6cc13b754b8250cc87fd1051714ce9a02b
First bad revision: 4a75d6afa43e263091d2bb2a40c30834d1212445
Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=01f72d6cc13b754b8250cc87fd1051714ce9a02b&tochange=4a75d6afa43e263091d2bb2a40c30834d1212445

  • Potentially regressed by: bug 1555771 Edouard can you please take a look at this?
Flags: needinfo?(eoger)
Whiteboard: [FxA]

[Tracking Requested - why for this release]:
This is primary UI that is supposed to reliably indicate to the user whether or not they're signed in to fxa.

Component: Server: Firefox Accounts → Firefox Accounts
Product: Cloud Services → Firefox
Summary: The Avatar picture is not restore to the default one, after you are sign out from your sync account → The Avatar picture is not restore to the default one, after you are sign out from your firefox account
Duplicate of this bug: 1564876
Flags: needinfo?(eoger)
Whiteboard: [FxA] → [FxA][checkin-needed]
Pushed by rvandermeulen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1edf0457ac23
Fix fxa avatar not clearing on sign out r=eoger

For future reference, checkin-needed is normally a bug keyword, not something added to the whiteboard. That'll allow Pulsebot to automatically clear it too :)

Assignee: nobody → vbudhram
Whiteboard: [FxA][checkin-needed] → [FxA]
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70

Please nominate this for Beta approval when you get a chance. Also, let's have QA verify this fix.

Flags: qe-verify+
Flags: needinfo?(vbudhram)

I tested this on Mac OS X 10.14 and Windows 10 with FF Nightly 70.0a1 (2019-07-11) and I can confirm the fix.

Status: RESOLVED → VERIFIED
Flags: qe-verify+

I will NI? myself to verify this after is uplifted.

Flags: needinfo?(ovidiu.boca)
Attached patch avatar_picture_fix.patch (obsolete) — Splinter Review

Beta/Release Uplift Approval Request

  • User impact if declined: Fxa toolbar menu will show the user's avatar after they log out
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Sign into Firefox Account with a profile picture set, then log out.
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This change isn't risky because this error only occurs on log out and if a user set a custom avatar. Additionally, this patch only removes 1 css variable from the FxA avatar element when a log out event is detected.
  • String changes made/needed:
Flags: needinfo?(vbudhram)
Attachment #9078139 - Flags: approval-mozilla-beta?
Attachment #9077108 - Flags: approval-mozilla-beta?
Flags: qe-verify+

Comment on attachment 9077108 [details]
Bug 1564877 - Fix fxa avatar not clearing on sign out

Fixes some FxA avatar issues. Approved for 69.0b5.

Attachment #9077108 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #9078139 - Attachment is obsolete: true
Attachment #9078139 - Flags: approval-mozilla-beta?
QA Whiteboard: [qa-triaged]

I tested this on Mac OS X 10.14 and Windows 10 x64 with FF Beta 69.0b5 and I can confirm the fix.

QA Whiteboard: [qa-triaged]
Flags: qe-verify+
Flags: needinfo?(ovidiu.boca)
You need to log in before you can comment on or make changes to this bug.