Closed Bug 1564897 Opened 4 months ago Closed 3 months ago

build failure on OpenBSD on buildid.cpp dependencies since #1551639

Categories

(Firefox Build System :: General, defect)

Unspecified
OpenBSD
defect
Not set

Tracking

(firefox-esr60 unaffected, firefox-esr68 unaffected, firefox68 unaffected, firefox69- fixed, firefox70 fixed)

RESOLVED FIXED
mozilla70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 - fixed
firefox70 --- fixed

People

(Reporter: gaston, Assigned: gaston)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

69.0b3 fails:

gmake[3]: Entering directory '/usr/obj/ports/firefox-69.0beta3/build-amd64/toolkit/library'                                                
gmake[3]: *** No rule to make target 'libxul_so.84.0.list', needed by '.deps/buildid.cpp.stub'.  Stop. 

That seems to point at https://searchfox.org/mozilla-central/source/toolkit/library/moz.build#387 - /usr/obj/ports/firefox-69.0beta3/build-amd64/toolkit/library/libxul_so_84_0.list is generated, but the dependency declared in backend.mk is libxul_so.84.0.list:

../build-amd64/toolkit/library/backend.mk:$(MDDEPDIR)/buildid.cpp.stub: /usr/obj/ports/firefox-69.0beta3/firefox-69.0/toolkit/library/gen_buildid.py libxul_so.84.0.list
../build-amd64/toolkit/library/backend.mk:      $(call py_action,file_generate,/usr/obj/ports/firefox-69.0beta3/firefox-69.0/toolkit/library/gen_buildid.py main buildid.cpp $(MDDEPDIR)/buildid.cpp.pp $(MDDEPDIR)/buildid.cpp.stub libxul_so.84.0.list)  

On OpenBSD, DLL_SUFFIX contains .so.X,Y which is our versioning - seems more dots should be stripped/replaced by underscores ?

 libxul_list = '%sxul_%s' % (
-        CONFIG['DLL_PREFIX'], CONFIG['DLL_SUFFIX'].lstrip('.'))
+        CONFIG['DLL_PREFIX'], CONFIG['DLL_SUFFIX'].lstrip('.').replace('.','_'))

works, but feels a bit .. ugly. mike, your opinion ?

Flags: needinfo?(mh+mozilla)
Flags: needinfo?(mh+mozilla)

I realized that no patch was posted for this bug and because of it mozilla-beta still fails to build on OpenBSD.

If not too late i'd like it to make 69 (i know, unlikely, but worth a try).

mike, can you review this ? (yeah i havent adapted to the phabricator thing and am not planning to, ENOTIME)

Assignee: nobody → landry
Attachment #9086580 - Flags: review?(mh+mozilla)
Comment on attachment 9086580 [details] [diff] [review]
replace remaining dots by underscores when formatting libxul_list

Review of attachment 9086580 [details] [diff] [review]:
-----------------------------------------------------------------

The patch needs an update on its header to be easily applied (author, etc.), and should probably refer to moz.build rather than moz.build.orig.
Attachment #9086580 - Flags: review?(mh+mozilla)
Attachment #9086580 - Attachment is obsolete: true
Attachment #9086930 - Flags: review?(mh+mozilla)
Attachment #9086930 - Flags: review?(mh+mozilla) → review+

[Tracking Requested - why for this release]:
Fix build failure on OpenBSD only - not landed yet on m-c but would be nice to have in 69.

Keywords: checkin-needed

Pushed by csabou@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/aab4f9e088d1
replace remaining dots by underscores when formatting libxul_list r=glandium

Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70

Please nominate this for Beta approval when you get a chance. We're building the Fx69 RC next week.

Comment on attachment 9086930 [details] [diff] [review]
replace remaining dots by underscores when formatting libxul_list

Beta/Release Uplift Approval Request

  • User impact if declined: Build failure, patched locally in OpenBSD packaging
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Only concerns OpenBSD where libraries are named libfoo.so.X.Y because DLL_SUFFIX is versioned. On other operating systems DLL_SUFFIX is .so.
  • String changes made/needed: none
Flags: needinfo?(landry)
Attachment #9086930 - Flags: approval-mozilla-beta?
Comment on attachment 9086930 [details] [diff] [review]
replace remaining dots by underscores when formatting libxul_list

OpenBSD build fix. Approved for 69.0rc1.
Attachment #9086930 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.