Closed Bug 1565180 Opened 5 months ago Closed 5 months ago

Update Thunderbird modifications to about:addons

Categories

(Thunderbird :: Add-Ons: General, task)

task
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 70.0

People

(Reporter: darktrojan, Assigned: darktrojan)

References

Details

Attachments

(1 file, 1 obsolete file)

Firefox has a rewritten about:addons page. We need to update the changes we make to it.

See Also: → 1558860

Sort of, I've got two things to do and was going to do both here, but since that also exists, it can be part 1 and this can be part 2.

Depends on: 1565177

This patch restores most of the modifications we made to about:addons. Not the message at the top about updating extensions, which I think should've been removed about now anyway.

I also haven't yet brought back an "undo" button when a legacy extension changes, and the version number on the extension detail page is probably wrong if an upgrade or downgrade is in progress. I left behind some of the pieces needed to fix them if that ever happens.

Attachment #9078094 - Flags: review?(richard.marti)
Duplicate of this bug: 1566082
Comment on attachment 9078094 [details] [diff] [review]
1565180-update-about-addons-1.diff

Review of attachment 9078094 [details] [diff] [review]:
-----------------------------------------------------------------

I observed this things:
 * dragging an extension on the Add-on page works for me only when I place it over the categories or in the header above the extensions list. Over the extensions list I get a "not allowed" mouse pointer. In FX this works.
 * remove an extension isn't possible. I get a TypeError: windowRoot.ownerGlobal.promptRemoveExtension is not a functionaboutaddons.js:1639:40

::: mail/base/content/aboutAddonsExtra.css
@@ +1,3 @@
> +/* This Source Code Form is subject to the terms of the Mozilla Public
> + * License, v. 2.0. If a copy of the MPL was not distributed with this
> + * file, You can obtain one at http://mozilla.org/MPL/2.0/. */

We have the MPL boilerplate now two times in this file. Please remove one.
Attachment #9078094 - Flags: review?(richard.marti)
Attachment #9078094 - Attachment is obsolete: true
Attachment #9078316 - Flags: review?(richard.marti)

(In reply to Richard Marti (:Paenglab) from comment #5)

I observed this things:

  • dragging an extension on the Add-on page works for me only when I place
    it over the categories or in the header above the extensions list. Over the
    extensions list I get a "not allowed" mouse pointer. In FX this works.
  • remove an extension isn't possible. I get a TypeError:
    windowRoot.ownerGlobal.promptRemoveExtension is not a
    functionaboutaddons.js:1639:40

Neither of those are really what I'm trying to fix here, although I did now fix add-on removal as it's important for this patch.
I'm sure that Firefox had to fix a bug about dropping an add-on, I guess we'll have to find and port it.

::: mail/base/content/aboutAddonsExtra.css
@@ +1,3 @@

+/* This Source Code Form is subject to the terms of the Mozilla Public

We have the MPL boilerplate now two times in this file. Please remove one.

Uhh, whoops. Coding while tired.

Comment on attachment 9078316 [details] [diff] [review]
1565180-update-about-addons-2.diff

Thanks. Removing works now. Also thanks for adding the abuseReport pref. If we need it we can change `extensions.abuseReport.url` to point to ATN.

Could you file a bug about the dragging of extensions not working over the extensions list?
Attachment #9078316 - Flags: review?(richard.marti) → review+
Keywords: checkin-needed
See Also: → 1566347

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/26f109dd92ca
Update Thunderbird modifications to about:addons. r=Paenglab

Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 70.0
Duplicate of this bug: 1554612
You need to log in before you can comment on or make changes to this bug.