link does not work if page has a vertical scrollbar

VERIFIED DUPLICATE of bug 156525

Status

()

Core
Layout
--
critical
VERIFIED DUPLICATE of bug 156525
16 years ago
16 years ago

People

(Reporter: OstGote!, Assigned: Marc Attinasi)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
Bug tested on Windows 2000, Windows NT 4.0 and Windows 98 with Mozilla, NS7 and
K-Meleon. Probably an "All OS" bug.

Mozilla 1.1 alpha
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1a) Gecko/20020611
Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.1a+) Gecko/20020623
Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.1a+) Gecko/20020704, Build ID
2002070408

Mozilla 1.0
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc3) Gecko/20020523, Build
ID 2002052306
Mozilla/5.0 (Windows; U; Win98; de-AT; rv:1.0.0) Gecko/20020530

Netscape 7.0pr1
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc2) Gecko/20020512
Netscape/7.0b1

K-Meleon 0.6.5 build 44 (compiled 20020201)
UA default: Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:0.9.9) Gecko/20020311


The URL above contains a page with a large picture and one link at the bottom of
the page. If your browser window is so small that you have vertical scrollbars
visible, then you can't follow the link right down at the bottom. The only
effect of the click on it is a scrolling of the page upwards. The same happens
if you try to view the context menu for that link.

It is not an HTML issue, because if the page fits into the window the link
works. Other browsers (IE, Opera, NS 4.7x) do not have that behaviour.

Reproducible: Always (it will work seldom only after the 2nd try)
Steps to Reproduce:
1. Open a new browser window.
2. Resize the window so it will match the following size:
   width >= 580 px, height <= 760 px
3. Open the URL from the URL field
4. Check if you have ONLY the vertical scrollbar visible (if not, restart)
5. Scroll down the page till the end
6a. Click the link named "weiter" (German for "next") to go to the next page
6b. or open the context menu for that link

Note: The link on the second page leads to an error 404, that's by design :-)

Actual Results: The new page does not open in the window, the only thing that
happens is upward scrolling of the page (over the middle of the page). Same
result if you try to open the context menu of the link.

Expected Results: Link should open in the current browser window. Context menu
should work.

I think this is a critical bug, because in such cases the links don't work and
it seems that Mozilla is broken.
(Reporter)

Comment 1

16 years ago
I don't know why this bug was filed twice ...

*** This bug has been marked as a duplicate of 156525 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Updated

16 years ago
QA Contact: petersen → moied

Comment 2

16 years ago
vrfy dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.