Closed Bug 1565375 Opened 2 years ago Closed 2 years ago

The pause overlay should include stepping buttons

Categories

(DevTools :: Debugger, enhancement, P2)

enhancement

Tracking

(firefox71 fixed)

RESOLVED FIXED
Firefox 71
Tracking Status
firefox71 --- fixed

People

(Reporter: jlast, Assigned: davidwalsh)

References

(Blocks 1 open bug)

Details

(Whiteboard: [debugger-mvp])

Attachments

(1 file)

The stepping buttons in the pause overlay are currently hidden by the flag devtools.debugger.features.overlay-step-buttons because we could not figure out how to have CSS hoverstates (basically change the mouse to a pointer when the user havers on the button). I think this is because setSuppressedEventListener needs to be taught about hover states.

Relevant links:

Blocks: dbg-70
Priority: -- → P2
Whiteboard: [debugger-mvp]

Brian, could you help us with this?

Assignee: nobody → bhackett1024
Whiteboard: [debugger-mvp] → [debugger-reserve]

I don't think this is as important as some of the other tasks. It's fine if this waits until the next release.

Assignee: bhackett1024 → nobody
No longer blocks: 1354679
Assignee: nobody → jlaster
Status: NEW → ASSIGNED
Duplicate of this bug: 1353564
Duplicate of this bug: 1568693
Assignee: jlaster → dwalsh
Blocks: dbg-71
No longer blocks: dbg-70
Whiteboard: [debugger-reserve] → [debugger-mvp]
Pushed by dwalsh@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/32c411bdad8d
The pause overlay should include stepping buttons. r=jlast
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71
You need to log in before you can comment on or make changes to this bug.