Closed Bug 1565414 Opened 4 months ago Closed 4 months ago

Update audit functionality to include warnings and best practices results.

Categories

(DevTools :: Accessibility Tools, defect)

defect
Not set

Tracking

(firefox69 fixed, firefox70 fixed)

RESOLVED FIXED
Firefox 70
Tracking Status
firefox69 --- fixed
firefox70 --- fixed

People

(Reporter: yzen, Assigned: yzen)

Details

Attachments

(1 file)

Right now when performing audit, we exclude audit reports that are not reports with FAIL scores. We recently added two more levels (WARNING, and BEST_PRACTICES) for text label audit and the filter needs to be updated.

Bugbug thinks this bug is a task, but please change it back in case of error.

Type: defect → task
Type: task → defect
Pushed by yura.zenevich@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/a1de1cc0d30d
update audit functionality to include warnings and best practices results. r=mtigley
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70

Comment on attachment 9077573 [details]
Bug 1565414 - update audit functionality to include warnings and best practices results. r=mtigley

Beta/Release Uplift Approval Request

  • User impact if declined: Users will not see a full audit within the accessibility panel because without this patch it only displays failures and not warnings or best practices cases.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Just including 2 more filters for the a11y panel audit.
  • String changes made/needed: none
Attachment #9077573 - Flags: approval-mozilla-beta?

Comment on attachment 9077573 [details]
Bug 1565414 - update audit functionality to include warnings and best practices results. r=mtigley

a11y panel improvements. Approved for 69.0b6.

Attachment #9077573 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.