Closed Bug 1565473 Opened 5 months ago Closed 5 months ago

Periodic text rendering glitches (WebRender only? DPI related?)

Categories

(Core :: Graphics: WebRender, defect, P1)

69 Branch
Desktop
All
defect

Tracking

()

RESOLVED DUPLICATE of bug 1566712
Tracking Status
firefox69 --- fixed
firefox70 --- fixed

People

(Reporter: kael, Assigned: gw)

References

Details

(Keywords: correctness, regression)

Attachments

(6 files)

Attached image image.png

This is either a recent regression across all renderers, or a rendering glitch caused by turning on WebRender (I never saw it before WR).

Pretty frequently roughly 1-2 horizontal rows of pixels on each page have text messed up. Backgrounds and other elements seem to render fine, just not text. Scrolling the messed up section away sometimes fixes it, but other times not. For example the text field on this Bugzilla page glitched out but if I scroll the text up it's fine (until I scroll it back down).

This might be related to Windows HiDPI compositing, because I usually see it on my 100% DPI monitor (my other monitor is 150%).

Attached image quad misalignment

Also just noticed some triangular rasterization problems on bugzilla, this one on my main (150%) monitor. Haven't noticed it before, might be bugzilla specific?

Attached image image.png

It appears on twitter too, but does not appear to 'stick' in position if I scroll the page and does not affect UI chrome.

The triangular thing went away on a FF restart, fwiw. I tried some basic ways to reproduce it and couldn't.

Might be related to the issues I'm seeing on macos in Bug 1563783.

Blocks: wr-69
Priority: -- → P1

Could you attach your about:support details? Might help us find a configuration to reproduce this.

Flags: needinfo?(kg)

I might have seen similar with Mesa/Nvidia GTX1060/Debian Testing (2560x1440), but only once so far.

OS: Windows 10 → All

I have noticed the exact same problem. I see it very often when browsing forums as it seems to be related to how long a page is. Take this page from SA:

https://forums.somethingawful.com/showthread.php?noseen=0&threadid=3817104&perpage=40&pagenumber=307

First: https://i.imgur.com/mlqUafo.png
Second: https://i.imgur.com/PwBepzQ.png

As you scroll up and down the page, you will see the corruption change locations. The two images I linked are the two most common spots, but depending on how you scroll up and down, the corruption can be found in other places too. This only started happening in the Firefox 69 Beta. I didn't see this in Firefox 68.

Attached file about_support_j.txt

I've attached my about:support data.

Attached file about:support
Flags: needinfo?(kg)

Also noticed this with the 69 update. I see it both on macOS and Windows. It does not appear to happen on every site it seems. I consistently see it on GitHub, but not here on Bugzilla. In all cases, my webpages are zoomed in slighly (120%).

Edit: Actually issue does not appear with both gfx.webrender.all: false and gfx.webrender.enabled: false, so it's a webrender bug.

Duplicate of this bug: 1565968
Duplicate of this bug: 1563783
Assignee: nobody → a.beingessner

Alexis has a capture of this happening so that's a good place to start debugging from.

See Also: → 1541072

The potential fix in Bug 1566712 is in the latest nightly (70.0a1 (2019-07-18)), so if you update and don't see this issue anymore after a few days, let us know so we can uplift the fix to beta.

(we're having trouble producing portable tests for this issue, exactly how to trigger it is slightly system-specific)

Just to follow up - that patch got backed out overnight, so it (probably?) won't be in the next nightly. I'm going to investigate the reason it got backed out today and try to get it re-landed asap.

See Also: → 1563983
Duplicate of this bug: 1563983

Has anyone seen this with a build newer than 20190719094503?

I personally haven't had any issues since bug 1566712 landed. Everything alright on your end too, kael?

Flags: needinfo?(kg)

assigning to gw since he fixed the issue, but happy to pick this back up if it some are still seeing this.

Assignee: a.beingessner → gwatson

I saw it yesterday, but I'm running dev edition, not nightly. Should I make a backup of my profile and then test in nightly for a bit?

Flags: needinfo?(kg)

DevEdition 69.0b7 or later should also have the fix. Given that it was only released yesterday, I could see you maybe not have gotten that update yet then.

Please leave a comment or reopen this bug in case you see it again. I saw it on Reddit, but bug 1566712 fixed it.

Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1566712
You need to log in before you can comment on or make changes to this bug.