Closed Bug 1565507 Opened 4 months ago Closed 3 months ago

The default system theme is not automatically enabled when an installed theme is Removed

Categories

(Toolkit :: Add-ons Manager, defect, P1)

defect

Tracking

()

VERIFIED FIXED
mozilla70
Tracking Status
firefox-esr68 --- wontfix
firefox68 --- wontfix
firefox69 --- verified
firefox70 --- verified

People

(Reporter: amoga, Assigned: robwu)

References

Details

Attachments

(3 files, 1 obsolete file)

[Tested platforms]

  • Win10x64
  • macOS High Sierra 10.13.6

[Steps to reproduce]

  1. Open about:addons
  2. Install one of the Recommended themes (or a theme from AMO)
  3. Remove the theme
  4. Observe the status of the Default system theme

[Expected result]
The default system theme is automatically re-enabled when an installed theme is Removed

[Actual result]
The default system theme remains disabled when a theme is Removed

Notes:

  • if you Disable the installed theme before Removing it, the issue will not reproduce
  • the issue becomes even more visible when a dark system theme is set on the user's machine - in this case the header will receive a dark gray color
  • restarting the browser doesn't fix the issue

The old about:addons was faking the pending uninstall for themes by disabling them [1] and setting the pending="uninstall" attribute. We could do something similar here, or stop doing pending uninstalls for themes (we'll likely remove it for extensions too, but maybe best to do that together).

[1] https://searchfox.org/mozilla-central/rev/cbde79674f616a1c6e71dd4d15a09789cdfaa391/toolkit/mozapps/extensions/content/extensions.xml#1265-1272

Assignee: nobody → mstriemer
Priority: -- → P1
Duplicate of this bug: 1568766
Assignee: mstriemer → rob
Status: NEW → ASSIGNED
Attachment #9080676 - Attachment is obsolete: true
Pushed by rob@robwu.nl:
https://hg.mozilla.org/integration/autoland/rev/f665f6ac47a9
Enable default theme on theme uninstallation r=aswan
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70

Rob, would that be a safe patch to uplift to beta? If you feel this is a good candidate, please propose it for uplifting to 69, thanks.

Flags: needinfo?(rob)

Comment on attachment 9080675 [details]
Bug 1565507 - Enable default theme on theme uninstallation

Beta/Release Uplift Approval Request

  • User impact if declined: When a theme is uninstalled, the default theme is not re-enabled (the Themes list only shows "Disabled" themes, none of them are "Enabled").
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): The patch includes multiple unit tests. One test for the about:addons UI, and more unit tests to verify the behavior of the internals.
  • String changes made/needed: none
Flags: needinfo?(rob)
Attachment #9080675 - Flags: approval-mozilla-beta?

Verified fixed in latest Nightly with Win10x64 and macOS High Sierra 10.13.6

Status: RESOLVED → VERIFIED
Attached image postfix.gif

Comment on attachment 9080675 [details]
Bug 1565507 - Enable default theme on theme uninstallation

Approved for 69.0b13. Thanks for including new tests for this.

Attachment #9080675 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

This is also verified fixed in 69.0b13.

You need to log in before you can comment on or make changes to this bug.