Closed Bug 1565840 Opened 3 months ago Closed 3 months ago

cmd_killThread command: TypeError: this.notificationbox is undefined

Categories

(Thunderbird :: Mail Window Front End, defect)

defect
Not set

Tracking

(thunderbird68+ fixed, thunderbird69 fixed, thunderbird70 fixed)

RESOLVED FIXED
Thunderbird 70.0
Tracking Status
thunderbird68 + fixed
thunderbird69 --- fixed
thunderbird70 --- fixed

People

(Reporter: alta88, Assigned: alta88)

References

Details

(Keywords: regression)

Attachments

(1 file)

when attempting to uncheck an 'ignore thread' menuitem. The notificationbox doesn't belong to DefaultController but to FolderPaneController, so can't use |this| there.

Keywords: regression

Alex, you worked on notification stuff, could you please take a look.

OK, on the message menu, "Ignore Thread" has a check mark, but on the context menu it doesn't have one. That's a bug too, right?

Looks like ignore sub-thread doesn't work either.

An error occurred executing the cmd_killThread command: TypeError: this.notificationbox is undefined globalOverlay.js:83
goDoCommand chrome://global/content/globalOverlay.js:83
oncommand chrome://messenger/content/messenger.xul:1

Flags: needinfo?(alessandro)

easy fix, change |this| to |FolderPaneController| in two places, here and just below:
https://searchfox.org/comm-central/source/mail/base/content/mail3PaneWindowCommands.js#703

it helps to have View-Threads-Ignored Threads checked, and have the thread column selected.

Patch as per comment #2, author Alta88. This seems to restore the original behaviour.

If you ignore a thread, "Ignore Thread" gets a check mark in the main window, but not in the context menu. Is that intentional? It's the same in TB 60 and TB 52, hmm.

Also, when I ignore a tread, I've see a case where the "Ignore Thread" item was greyed-out in the main menu, but now I can't reproduce it. Anyway, that's out of scope here.

Flags: needinfo?(alessandro)
Attachment #9078071 - Flags: review+
Attachment #9078071 - Flags: approval-comm-beta+
Assignee: nobody → alta88
Status: NEW → ASSIGNED
Component: General → Mail Window Front End

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/dd1eac384cfd
fix access to notification box for 'Ignore (Sub)Thread'. r=jorgk DONTBUILD

Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 70.0

(In reply to Jorg K (GMT+2) from comment #3)

If you ignore a thread, "Ignore Thread" gets a check mark in the main window "message" menu, but not in the context menu. Is that intentional? It's the same in TB 60, TB 52, TB 38 and TB 24, hmm. The context menu has provision for a checkbox.

Magnus, Alta88, is that intentional or a bug?

Flags: needinfo?(mkmelin+mozilla)
Flags: needinfo?(alta88)

I get a checkmark in the context menu too (linux, trunk).

Flags: needinfo?(mkmelin+mozilla)

Filed bug 1566027 for the missing check mark. Strange that no one has complained since TB 24.

Flags: needinfo?(alta88)
Duplicate of this bug: 1558632
You need to log in before you can comment on or make changes to this bug.