Closed Bug 1565863 Opened 1 year ago Closed 1 year ago

Fennec Nightly download URL for latest version is broken

Categories

(Webtools :: Bouncer, defect)

All
Android
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: sdk, Unassigned)

References

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:70.0) Gecko/20100101 Firefox/70.0

Steps to reproduce:

  1. Open URL https://download.mozilla.org/?product=fennec-nightly-latest&os=android&lang=multi

Actual results:

Download URL for the latest Nightly redirect to the wrong Fennec version (68.0a1 instead of 68.1a1)

Expected results:

It should redirect to 68.1a1

PS. Is there any plan to support Firefox Update on Android without Google Play Store?

Blocks: ESR-Fennec

(In reply to Danny Colin [:sdk] from comment #0)

PS. Is there any plan to support Firefox Update on Android without Google Play Store?

There is a bug on file for this with some discussion.

Not sure how relevant it is now that Fennec is in the process of being replaced by a new app (Firefox Preview); perhaps someone should file a new bug for non-Play Store updates of that.

Hello, I can confirm that this issue is reproducible using the link provided in the description using the following devices:

  • Samsung Galaxy Note 8 (Android 9);
  • Samsung Galaxy Tab S3 (Android 8.0);
  • Nokia 6 (Android 7.1.1).

Builds:

  • Nightly 68.1a1 (2019-07-13);
  • Release 68.0.

Due to my findings, I'll make this issue as New, thanks.

Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Unspecified → Android
Hardware: Unspecified → All
Product: Firefox for Android → www.mozilla.org
Version: Firefox 68 → Production

The URL in the description works for me, but I'm moving this to the right component.

Component: General → Bouncer
Product: www.mozilla.org → Webtools
Version: Production → other

Mihai, is this something you can look at?

Flags: needinfo?(mtabara)

(In reply to Jeremy Orem [:oremj] from comment #4)

Mihai, is this something you can look at?

Might be a fallout from migration to esr68. Bouncer location for fennec-nightly-latest points indeed to 68.0a1 entries. So that explains why https://download.mozilla.org/?product=fennec-nightly-latest&os=android&lang=multi return the old one.

Looking at the most recent nightly graph, I don't see any bouncer job in the esr68 nightly graphs. Which makes me believe that this could have been skipped as part of the esr68 migration or alike.

Leaving the NI until we figure things out here.

This was indeed a tiny fallout from migrating the Fennec nightlies to esr68. Support to automate that is coming soon, but for now Johan updated the entries manually so that https://download.mozilla.org/?product=fennec-nightly-latest&os=android&lang=multi returns the correct values of 68.1a1.

Works for me for now so I'll close this. Feel free to re-open should you notice anything suspicious again.

Status: NEW → RESOLVED
Closed: 1 year ago
Flags: needinfo?(mtabara)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.