Closed Bug 1565881 Opened 1 year ago Closed 1 year ago

Search Engines missing in Sidebar Search and Settings

Categories

(SeaMonkey :: General, defect)

SeaMonkey 2.53 Branch
Unspecified
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: RainerBielefeldNG, Unassigned)

Details

(Whiteboard: w9gs)

User Story

Problem is related to Language pack

Attachments

(2 files)

Steps how to reproduce with Server Installation of unofficial (by wg9s) en-US SeaMonkey 2.53 (NT 6.1; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0 Build 20190709130007 (Default Classic Theme, German Language Pack active) on German WIN7 64bit:

Compare listed search engines in Sidebar Panel or 'Edit → Settings → Browser → Internet Search' in

  • older 2.53 Version: lots of Search engines ☺
  • Build 20190709130007 or later: lots of search engines, but different list order compared
    to the one you have been used to, and some search engines are missing 😥

Additional information
a) when you return to older build missing Search Engines will reappear

It seems to be the standard search engines at the end are gone from the new build. Order and everything else seems to be the same. I only have 5 and can't currently reproduce it. Are they shown in preferences?

Sometimes that build even launches with no Search Engine at all shown in Sidebar Panel (selector and "Manage ...").

(In reply to Frank-Rainer Grahl (:frg) from comment #1)

Are they shown in preferences?
Same view anywhere, same search engines missing in Sidebar Panel list, Sidebar Panel Search Engines Manager, Edit -> Preferences -> ...

Could you probably attach the search.json.mozlz4?

Flags: needinfo?(RainerBielefeldNG)
Attached file search.json.mozlz4

BTW: As long as it was at position 4 of the Search engines List and selected as default search engine, latest build launches without any visible and usable Search engine. Effect is visible in S.E.-list in Sidebar Panel, Manager-Pulldown in Sidebar Panel, Edit -> Preferences -> ...

After I switched StartPage position with AOO position and selected AOO search engine as default, now latest build also starts without visible usable Search engine. After having selected other Search Engine with Build 20190412032805, list of search engines reappears in latest build.

Effect is not limited to Position 4, but I did not do systematic testing for other problem causing positions.

Flags: needinfo?(RainerBielefeldNG)
Flags: needinfo?(frgrahl)

Still REPRODUCIBLE with unzipped unofficial (by wg9s) en-US SeaMonkey 2.53 (NT 6.1; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0 Build 20190801120006 (Default Classic Theme, older German Language Pack active) on German WIN7 64bit

👍 No longer reproducible after switch to frg's latest German language pack from https://wp.me/p5Y2Xy-to

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
User Story: (updated)
Resolution: --- → FIXED

Great. Just looked at the bug yesterday and felt somehwat guilty for not having found the time yet to look into it.

Flags: needinfo?(frgrahl)
You need to log in before you can comment on or make changes to this bug.