Closed Bug 1565923 Opened 1 year ago Closed 7 months ago

Unable to click results in glodacomplete-rich-result-popup

Categories

(Thunderbird :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 73.0

People

(Reporter: aleca, Assigned: aleca)

Details

(Keywords: regression)

Attachments

(1 file)

Selecting one of the suggested results in the autocomplete popup with the arrow keys and hitting enter always triggers the global search instead of the selected result.

Clicking on one of the results in the popup doesn't produce any outcome.

Correction!
This works as expected and it wasn't regressed by bug 1554637.

The problem appears while working on bug 1542720, with the temp patch applied.

No longer regressed by: 1554637

Confirmed that the issue appears when applying the WIP patch from https://phabricator.services.mozilla.com/D33250

I will hold on to this bug until that patch lands on m-c and do the necessary adjustments.

(In reply to Alessandro Castellani (:aleca) from comment #2)

Confirmed that the issue appears when applying the WIP patch from https://phabricator.services.mozilla.com/D33250

I will hold on to this bug until that patch lands on m-c and do the necessary adjustments.

That patch has landed, and Bug 1534455 has some noted regressions

Flags: needinfo?(alessandro)

This seems to be solved.
Can someone confirm it as well?

Flags: needinfo?(alessandro)

David, do you see this issue with current nightly?
(bug 1595884 was a mistake)

Flags: needinfo?(marks.david)

I didn't see the other bug as an error request. I am not using a Nightly at this time as too many addons were not usable when I last tried.

Flags: needinfo?(marks.david)

Here's a patch for this bug which fixes the current issue:

  • Search something.
  • Use the arrow keys to move through the popup results.
  • Hit Enter on one of the focused results.
  • The search gets triggered using what's written in the input field, ignoring the selected result in the popup.

This patch checks if a result in the popup is currently selected and forces a "popupClick" method instead of the default search based on the typed value.

Attachment #9115892 - Flags: review?(mkmelin+mozilla)
Comment on attachment 9115892 [details] [diff] [review]
1565923-autocomplete-results.patch

Review of attachment 9115892 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM, r=mkmelin
Attachment #9115892 - Flags: review?(mkmelin+mozilla) → review+
Status: NEW → ASSIGNED
Target Milestone: --- → Thunderbird 73.0

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/cd095c8109ff
Fix erratic behaviour when clicking results on the glodacomplete-rich-result-popup. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED

You should have requested backport for this for TB 72 beta. We got a complaint in bug 1490428 comment #25 for which I filed bug 1608700. Please always think of all the versions bugs need to be fixed in.

You need to log in before you can comment on or make changes to this bug.