javascript:self.close() in a tabbed window closes the whole browser

VERIFIED DUPLICATE of bug 103452

Status

()

Core
JavaScript Engine
--
major
VERIFIED DUPLICATE of bug 103452
16 years ago
16 years ago

People

(Reporter: Amit K, Assigned: rogerl (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020529
BuildID:    2002052918

When i open a URL similar to the above in a tab and the then click on the image
thus invoking javascript:self.close(), it closes the whole browser

Reproducible: Always
Steps to Reproduce:
1.Open above URL in a separate tab
2.Click on the image


Actual Results:  The browser closes

Expected Results:  I am not sure if this is correct javascript behaviour. I
think that only the tab should have been closed, otherwise what's the use of the
tabbed interface

Comment 1

16 years ago
this has been fixed, but not in time for 1.0

*** This bug has been marked as a duplicate of 103452 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
Verified Duplicate -
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.