Closed Bug 1565981 Opened 5 years ago Closed 5 years ago

hex color notation issue after update to 68.0 for Firefox Quantun

Categories

(Core :: CSS Parsing and Computation, defect)

68 Branch
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: paraskevakosg, Unassigned)

References

(Regression)

Details

(Keywords: regression)

Attachments

(4 files)

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

I am using hex color notation in style.css with Firefox Quantum (64-bit).

Actual results:

In my style.css I have the following rule:
{
background: -moz-linear-gradient(center top ,#87C540,#A8EC58);
}
and from inspector I get : "Invalid property value".
On the other hand if I change it with rgb:
{
background: -moz-linear-gradient(rgb(135, 197, 64), rgb(168, 236, 88));
}
then CSS renders without issue in browser.

Expected results:

CSS for hex color notation should be rendered as it used to https://caniuse.com/#search=hex%20color%20notation.

same problem for me

Same also!

Could you please install the tool mozregression and try to narrow down a regression range?
See http://mozilla.github.io/mozregression/ for details.

Attached file mozregression.log
Attached image mozreg.JPG

Thanks a lot for the feedback Simona.

Attached you can find:
mozregression.log,
Bisection_information.log,
mozreg.jpg

I ran the regression and the following Bug ID was returned:

2019-07-22T19:38:05: INFO : Narrowed inbound regression window from [eb170900, a484a262] (3 builds) to [bd1d3ebd, a484a262] (2 builds) (~1 steps left)
2019-07-22T19:38:06: DEBUG : Found commit message:
Bug 1547939 - Add a pref for a simpler -moz- gradient parsing. r=dholbert

Relates with repo autoland : https://hg.mozilla.org/integration/autoland

Blocks: 1547939
Component: Untriaged → CSS Parsing and Computation
Keywords: regression
Product: Firefox → Core
Regressed by: 1547939

This is expected. We simplified the parsing of Mozilla-specific gradients to be less special and more similar to other gradients. That gradient simply doesn't work anymore.

Is there any site broken because of this? Or is this mozilla-specific CSS (like a theme or such)? I was careful of ensuring all the regressions of previous attempts at removing them weren't broken. You can use standard linear gradient syntax to achieve this, see https://developer.mozilla.org/en-US/docs/Web/CSS/linear-gradient.

The priority flag is not set for this bug.
:emilio, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(emilio)

This syntax was prefixed and mozilla-specific. You can accomplish the same with the standard gradient syntax that is supported everywhere.

I'm happy to help update the gradients if you have any questions or what not. But I think this is WONTFIX unless I get a reply to comment 10 and something is severely broken because of this.

Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Flags: needinfo?(emilio)
Resolution: --- → WONTFIX
Has Regression Range: --- → yes
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: