Closed Bug 1565992 Opened 1 year ago Closed 1 year ago

attendees dialog recipients area needs scrollbars when adding many invitees

Categories

(Calendar :: E-mail based Scheduling (iTIP/iMIP), defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: mkmelin, Assigned: mkmelin)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

+++ This bug was initially created as a clone of Bug #1530213 +++

In the invite attendees dialog the recipient area expands above the other things in the dialog if you invite enough people for there to be need for scroll bars.

Summary: Invite attendees doesn't expand mailing lists anymore → attendees dialog recipients area needs scrollbars when you many users as invitees

listboxbody is old junk
There needs to be a height for this to work (doesn't matter which, since the real height will get set by the vbox/hboxes), so I set it to 250px which is around what it is on my system.

Attachment #9078097 - Flags: review?(geoff)

Why is this richlistbox (and #freebusy-grid) set to display: flex? That's the real culprit. Set them to orient="vertical" instead.

The scrollbar on the grid is supposed to also control the attendee list. It's a bit unreliable in practice but it's far from the worst thing about this dialog.

Attachment #9078097 - Flags: review?(geoff) → review-

Ah, I see now.
Agreed there's lots of room for improvements here. It really could be so much more useful.

Attachment #9078097 - Attachment is obsolete: true
Attachment #9078331 - Flags: review?(geoff)
Duplicate of this bug: 1566217
Attachment #9078331 - Flags: review?(geoff) → review+
Keywords: checkin-needed

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/f4e5910b4eed
attendees dialog recipients area needs scrollbars when adding many invitees. r=darktrojan

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Keywords: checkin-needed
Resolution: --- → FIXED
Attachment #9078331 - Flags: approval-calendar-esr?(philipp)
Attachment #9078331 - Flags: approval-calendar-beta?(philipp)

Magnus, can you check the commit message before requesting checkin. The patch had:
attendees dialog recipients area needs scrollbars when you many users as invitees
Also, please request uplift straight away since approvals in Calendar take a long time.

Philipp, we still need 7.2 as a target here.

Flags: needinfo?(philipp)
Target Milestone: --- → 7.1
Summary: attendees dialog recipients area needs scrollbars when you many users as invitees → attendees dialog recipients area needs scrollbars when adding many invitees

In TB 68 it looks woeful when you expand a long mailing list, works nicely in Daily ... EDIT: and 69 beta.

Status: RESOLVED → VERIFIED
Attachment #9078331 - Flags: approval-calendar-esr?(philipp)
Attachment #9078331 - Flags: approval-calendar-esr+
Attachment #9078331 - Flags: approval-calendar-beta?(philipp)
Attachment #9078331 - Flags: approval-calendar-beta+
You need to log in before you can comment on or make changes to this bug.