Closed Bug 1565998 Opened 6 months ago Closed 4 months ago

Cookies from Local files lack path/name in the Manage Cookies modal

Categories

(Firefox :: Preferences, defect, P2, minor)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
Firefox 71
Tracking Status
firefox-esr60 --- wontfix
firefox-esr68 --- wontfix
firefox67 --- wontfix
firefox68 --- wontfix
firefox69 --- wontfix
firefox70 --- wontfix
firefox71 --- verified

People

(Reporter: cfogel, Assigned: Gijs)

References

(Blocks 2 open bugs)

Details

Attachments

(3 files)

Attached file cookies.html

Affected versions

  • 60.8.0esr, 68.0, 69.0b4 , 70.0a1 (2019-07-11)

Affected platforms

  • Windows 10, MacOS 10.11, Ubuntu 16.04;

Steps to reproduce

  • try with a fresh profile or clear cookie Data before;
  1. Launch Firefox;
  2. Open the TC file;
  3. Input any value in the modal-popUp;
  4. Access about:preferences#privacy
  5. In the Cookies and Site Data section click on the Manage Data... button.

Expected result

  • Name or path for the file should be listed;

Actual result

  • The newly saved cookie has nothing listed in the Site field;

Regression range

  • not a regression, reproducible on older builds as well (such as 30.0a1);

Additional notes

  • attached TC file
Component: Canvas: 2D → Networking: Cookies
Attached image cookieLocalName.png

Attaching screenshot with the potential issue.

Component: Networking: Cookies → Preferences
Product: Core → Firefox
See Also: → 1560865
Flags: needinfo?(gijskruitbosch+bugs)
Priority: -- → P2

Yeah I think all this needs really is some special-casing for host-less origins in SiteDataManager.jsm

Flags: needinfo?(gijskruitbosch+bugs)
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED

Needinfo for https://phabricator.services.mozilla.com/D44832#inline-282786 because I don't know how to fix this up for review without understanding the feedback there.

Flags: needinfo?(amarchesini)
Flags: needinfo?(amarchesini)
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/314a0fee08fd
display a descriptive text for local file: related data, and allow removing it, r=johannh,fluent-reviewers,flod,baku
Duplicate of this bug: 1560865
See Also: 1560865
Blocks: 1102808
Blocks: 1585694
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71

Fix confirmed with 71.0a1 (2019-10-13).

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.