Identify pages viewed as source in title

RESOLVED FIXED in Camino0.8

Status

--
enhancement
RESOLVED FIXED
17 years ago
15 years ago

People

(Reporter: sagemane+bugzilla, Assigned: mikepinkerton)

Tracking

unspecified
Camino0.8
PowerPC
Mac OS X

Details

(URL)

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

17 years ago
In Chimera/20020709 on Mac OS 10.1.5, if you view the source of a page in a new
window or tab, the title of the source's window or tab is the URL of the page
you are viewing the source of, but it does not identify itself as being source
code in the title.

For example, if you go to apple.com and view the source, the title of the source
window or tab will be, "http://www.apple.com/". It would be more clear if the
window were named, "Source of http://www.apple.com"

Mozilla names source windows "Source of: http://www.somewebsite.com - Mozilla"
so this is a Chimera-specific issue.

Comment 1

17 years ago
Confirmed using Chimera/20020708. Steve's suggestion is a good one (but let's
not append "- Chimera" à la Mozilla here).
Summary: [RFE] Identify pages viewed as source in title → Identify pages viewed as source in title

Comment 2

16 years ago
Created attachment 108667 [details] [diff] [review]
Adds localizable 'Source of ' before view-source tabs and windows

Adds localizable 'Source of ' before view-source tabs and windows.

Comment 3

16 years ago
Mine.
Assignee: saari → sfraser

Comment 4

15 years ago
Bump. Could this land, seems like a very simple solution to something that might
irritate people.

Comment 5

15 years ago
Please review. Or check in.

Comment 6

15 years ago
Mike.

Comment 7

15 years ago
Mike I'm putting this on the 0.8 list since it's such a nice patch. I have been
running this patch i one of David Haas's builds and never encountered problems.

It's a small detail just like the one that changes the window title when in
Bookmarks view mode.

Reset as needed.
Target Milestone: --- → Camino0.8
(Assignee)

Comment 8

15 years ago
this patch isn't l10n savvy, but it should be easy to make it so. working on it
and will land.
Assignee: sfraser → pinkerton
(Assignee)

Comment 9

15 years ago
cleaned up and landed.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 10

15 years ago
Pretty big problem... Load your home page, select view source from the menu,
then flip back and forth from the source page and the original a few times.
Notice that the title of the source view tab gets "Source of " prefixed to it
multiple times. Shouldn't be too hard to fix.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 11

15 years ago
Created attachment 141697 [details] [diff] [review]
tabbing/window titles cleanup

This patch fixes the problem where "Source of " duplicates when tabbing and
cleans up the code for the entire method in charge of that.

Comment 12

15 years ago
I found out that my patch causes this failure when switching back and forth
between the original and source view tabs:

2004-02-18 16:41:06.452 Camino[12200] *** Assertion failure in -[BrowserWindow
setTitle:], AppKit.subproj/NSWindow.m:1490

2004-02-18 16:41:06.523 Camino[12200] Invalid parameter not satisfying: aString
!= nil

I don't have time to fix it now, but I will in a bit if nobody else does.

Comment 13

15 years ago
Created attachment 142184 [details] [diff] [review]
source text repeat patch v2
Attachment #141697 - Attachment is obsolete: true
(Assignee)

Comment 14

15 years ago
landed patch with tweaks.
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.