Closed Bug 1566077 Opened 3 months ago Closed Last month

Retriggers sometimes return problems retrieving data

Categories

(Tree Management :: Treeherder: Job Triggering & Cancellation, defect, P1)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: apavel, Assigned: camd)

References

Details

Attachments

(2 files)

I tried to retrigger https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&resultStatus=testfailed%2Cbusted%2Cexception&classifiedState=unclassified&selectedJob=256513218 and got the following: https://irccloud.mozilla.com/file/yPC0udh4/image.png

After ~1min passes, i'm able to do successful retriggers. This happens on random pushes, random jobs (looks like to me)

From IRC:
armenzg> The error comes from here https://github.com/mozilla/treeherder/blob/3038d08bbd690d54adc4c2d2e8623170e625d3f5/ui/models/push.js#L158

armenzg> when that happens you probably have some network fetches to the push api failing - I did not see anything unusual, however it might have refreshes as i hit the successful retriggers after

Flags: needinfo?(cdawson)
Assignee: nobody → cdawson
Status: NEW → ASSIGNED
Flags: needinfo?(cdawson)
Priority: -- → P1

Andreea: Do you keep hitting this? I'm trying to determine if it could have been a temporary network issue.

Flags: needinfo?(apavel)

Hi Cameron. Yes, this still occurs.

Flags: needinfo?(apavel)

Hi Cameron. I noticed today the error message improved :D

https://irccloud.mozilla.com/file/w6GBWdJ8/image.png

I just merged another PR. This should address all the 503s that you have been getting. I will request some testing on this once it has been deployed to stage.

Status: ASSIGNED → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Regressions: 1583132
You need to log in before you can comment on or make changes to this bug.