Closed Bug 1566086 Opened 1 year ago Closed 1 year ago

Crash in [@ -[nsTouchBar touchBarAction:]]

Categories

(Core :: Widget: Cocoa, defect, critical)

Unspecified
macOS
defect
Not set
critical
Points:
1

Tracking

()

RESOLVED FIXED
mozilla70
Iteration:
70.1 - Jul 8 - 21
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- wontfix
firefox68 --- wontfix
firefox69 --- fixed
firefox70 --- fixed

People

(Reporter: marcia, Assigned: harry)

Details

(Keywords: crash, regression)

Crash Data

Attachments

(1 file)

This bug is for crash report bp-d1b0b5d8-103d-4542-8e8f-a72a50190714.

Seen while looking at crash stats - small volume crash which appears to be related to the touch bar implementation. Earliest crash goes back to 20190618214619. ni on harry since he did the implementation.

URLs appear to be netflix and and another video site.

Top 10 frames of crashing thread:

0 XUL -[nsTouchBar touchBarAction:] widget/cocoa/nsTouchBar.mm:205
1 AppKit AppKit@0x2d022d 
2 AppKit AppKit@0x32f353 
3 AppKit AppKit@0x32f285 
4 AppKit AppKit@0x32f187 
5 AppKit AppKit@0x357e4e 
6 AppKit AppKit@0x4f48a5 
7 AppKit AppKit@0x4d7e78 
8 AppKit AppKit@0x5567a7 
9 AppKit AppKit@0x556607 

Flags: needinfo?(htwyford)

This crash report lists the OS as macOS 10.15. 10.15 is updating some of the Touch Bar APIs; it might be that on June 20, when the crash occurred, there was simply an issue with those APIs in an early beta of 10.15. With that said, I've attached a patch that will print a console warning and return if a similar issue occurs. This will at least give us some more information if this issue crops up again. As it stands, there's not much information with which to diagnose in this crash report.

Flags: needinfo?(htwyford)
Assignee: nobody → htwyford
Status: NEW → ASSIGNED
Points: --- → 1

If you back a little further, there was also one crash in the 69 cycle using 10.14: https://mzl.la/2LlOKhJ

Ah, thanks for pointing that out. The attached patch should stop the crash by returning early and give us a little more information through the console if more behaviour like this is encountered.

Iteration: --- → 70.1 - Jul 8 - 21
Pushed by htwyford@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/69020d38197b
Add error message if touchBarAction crash is encountered. r=spohl
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70

Should we backport this to Beta also?

Flags: needinfo?(htwyford)
Flags: needinfo?(htwyford)

Comment on attachment 9078248 [details]
Bug 1566086 - Add error message if touchBarAction crash is encountered. r?spohl!

Beta/Release Uplift Approval Request

  • User impact if declined: Potential crash when pressing items on the Mac Touch Bar.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): No user data is at risk. Note that this fix has not yet been verified. The original cause of the crash was not fully known, so rather than fixing the root cause, this patch adds a console warning and cancels the action that would otherwise cause the crash.

It has been verified, however, that if the new cancellation is encountered, the browser does not crash. I would say one press of a button being unresponsive is less annoying than a full crash, so it is worthwhile to uplift.

  • String changes made/needed:
Attachment #9078248 - Flags: approval-mozilla-beta?

Comment on attachment 9078248 [details]
Bug 1566086 - Add error message if touchBarAction crash is encountered. r?spohl!

Works around a crash by canceling the action instead and logging an error. Approved for 69.0b7.

Attachment #9078248 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.