Closed Bug 1566178 Opened 1 year ago Closed 4 months ago

Snapping issue with scroll anchoring when resizing the window

Categories

(Core :: Graphics: WebRender, defect, P3)

x86_64
Windows 10
defect

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 --- wontfix
firefox70 --- fixed

People

(Reporter: darkspirit, Assigned: gw)

References

(Blocks 2 open bugs, Regression, )

Details

(Keywords: correctness, nightly-community, regression)

Attachments

(3 files)

Attached video 2019-07-15 21-38-41.mp4

Win10/GTX1060, 2560x1440
This is the remaining part of bug 1554861.
STR: Scroll to the bottom. Resize window. Sometimes there is a line at the top that disappears when releasing the mouse. It seems this line is actually the page background.

Does not happen

  • without WebRender.
  • with WebRender and layout.css.scroll-anchoring.enabled;false.
  • [UPDATE] with WebRender and gfx.webrender.picture-caching;false. [/UPDATE]

Screencast:
mozregression --launch 2019-07-15 --pref gfx.webrender.all:true -a https://trac.edgewall.org/ticket/10002

Do we know what regressed this?

Flags: needinfo?(jan)

mozregression --good 2019-06-20 --bad 2019-07-15 --pref gfx.webrender.all:true -a https://trac.edgewall.org/ticket/10002

9:34.72 INFO: Last good revision: 021c05e47e6f4932a63fc1eeabc3c965fae6e882
9:34.72 INFO: First bad revision: c396b50af035b2205a3bc32190e105c97705c497
9:34.72 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=021c05e47e6f4932a63fc1eeabc3c965fae6e882&tochange=c396b50af035b2205a3bc32190e105c97705c497

c396b50af035b2205a3bc32190e105c97705c497 Glenn Watson — Bug 1560853 - Fix picture cache tiles with fractional origins. r=kvark

Before it was fine. Could it have caused bug 1541072 comment 19 and bug 1565473 comment 3 as well?

Flags: needinfo?(jan)
Assignee: nobody → gwatson

Clicked unaffected by accident. Confirmed, 69.0b4 is affected.

Has Regression Range: --- → yes
Attached video 2019-07-17 18-32-18.mp4

With try build from bug 1566712 comment 2. I can't reproduce the exact problem from comment 0. But at a different scroll position I am still able to reproduce something (similar to bug 1554861 and this bug, but different STR). Would a WR binary recording help?

Attached video 2019-07-17 18-53-40.mp4

Testcase from bug 1566517 has a similar problem:
At 15s and 18s text is cut off at the bottom.
Also focus on the first line of text: Sometimes it is cut off by some pixels too. (for example at 3s)

Screencast (250% zoom): mozregression --repo try --launch c37fe6296ec248161e57710c4dffcac65451b5ff --pref gfx.webrender.all:true gfx.webrender.debug.picture-caching:true -a https://bugzilla.mozilla.org/attachment.cgi?id=9078458

Should we mark this fixed and open a new bug for the above issue? Or are they similar enough to keep in this bug?

Flags: needinfo?(jan)

I can't reproduce the original bug report (which makes sense, we're fairly confident it was fixed by https://bugzilla.mozilla.org/show_bug.cgi?id=1566712).

With the follow up screen recordings, I was unable to reproduce the issue in https://bugzilla.mozilla.org/show_bug.cgi?id=1566178#c6.

I was able to reproduce the issue in https://bugzilla.mozilla.org/show_bug.cgi?id=1566178#c7 at the 250% zoom level.

I was also able to reproduce this in both beta and release builds, and also with WR disabled and D3D11 Advanced Layers enabled (although it seemed less repeatable / common in those other configurations).

If that's the case, it probably doesn't need to be a blocker for 69.

Darkspirit, any chance you could double check my findings above to confirm?

Blocks: wr-70
No longer blocks: wr-69
Priority: -- → P3
Assignee: gwatson → nobody

Marking as FIXED. If any issues remain please file a new bug.

Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Assignee: nobody → gwatson
Depends on: 1566712
Target Milestone: --- → mozilla70
Flags: needinfo?(jan)
You need to log in before you can comment on or make changes to this bug.