Closed Bug 1566180 Opened 4 months ago Closed 4 months ago

Update GMP fallback downloader for Widevine CDM 4.10.1440.19

Categories

(Core :: Audio/Video: Playback, task, P1)

Desktop
Unspecified
task

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox-esr60 --- fixed
firefox-esr68 --- fixed
firefox69 --- fixed
firefox70 --- fixed

People

(Reporter: bryce, Assigned: bryce)

References

Details

Attachments

(2 files)

As we're planning on updating the CDM to mitigate a MacOS 10.15 issue (see bug 1558924), we should update the fallback downloader so that the versions of the CDM match those being served by the balrog rules.

Adding the script I used to generate the file per my normal routine -- for posterity and for checking my working.

Update the fallback downloader to make sure it's in step with balrog rules.

Pushed by bvandyk@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/87634ce961fe
Update Widevine fallback downloader to 4.10.1440.19. r=rhelmer
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70

Comment on attachment 9081523 [details]
Bug 1566180 - Update Widevine fallback downloader to 4.10.1440.19. r?rhelmer

Beta/Release Uplift Approval Request

  • User impact if declined: If we use the fallback downloader URLs then users on MacOS Catalina may have failure to playback premium media due to having an unsigned CDM. I say "may", as the goalposts have shifted here during the Catalina beta such that it's possible a signed CDM lib will not be required by the time Catalina releases. However, we would rather be safe than sorry.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: This can be safely uplifted alone.
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Low risk as the fallback downloader is not expected to be used (only if the update service goes down). In addition to this, the CDM update from 4.10.1440.18 -> 4.10.1440.19 makes no changes to the Linux or Windows CDM, and only adds signing to the MacOS CDM, so we don't expect behaviour changes in the CDM.
  • String changes made/needed: None.
Attachment #9081523 - Flags: approval-mozilla-beta?

I plan to request uplift to the current ESRs also, but will do so once the CDM has baked in beta (which it currently is doing as the balrog rules have already been updated).

Comment on attachment 9081523 [details]
Bug 1566180 - Update Widevine fallback downloader to 4.10.1440.19. r?rhelmer

Approved for 69.0b14.

Attachment #9081523 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Comment on attachment 9081523 [details]
Bug 1566180 - Update Widevine fallback downloader to 4.10.1440.19. r?rhelmer

ESR Uplift Approval Request

  • If this is not a sec:{high,crit} bug, please state case for ESR consideration: Possible failure to playback premium video -- negative user impact.
  • User impact if declined: If we use the fallback downloader URLs then users on MacOS Catalina may have failure to playback premium media due to having an unsigned CDM. I say "may", as the goalposts have shifted here during the Catalina beta such that it's possible a signed CDM lib will not be required by the time Catalina releases. However, we would rather be safe than sorry.
  • Fix Landed on Version: 70.
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Low risk as the fallback downloader is not expected to be used (only if the update service goes down). In addition to this, the CDM update from 4.10.1440.18 -> 4.10.1440.19 makes no changes to the Linux or Windows CDM, and only adds signing to the MacOS CDM, so we don't expect behaviour changes in the CDM.
  • String or UUID changes made by this patch: None.
Attachment #9081523 - Flags: approval-mozilla-esr68?
Attachment #9081523 - Flags: approval-mozilla-esr60?

Comment on attachment 9081523 [details]
Bug 1566180 - Update Widevine fallback downloader to 4.10.1440.19. r?rhelmer

Updates the fallback URL for Widevine CDM downloads. Approved for ESR68 and ESR60.

Attachment #9081523 - Flags: approval-mozilla-esr68?
Attachment #9081523 - Flags: approval-mozilla-esr68+
Attachment #9081523 - Flags: approval-mozilla-esr60?
Attachment #9081523 - Flags: approval-mozilla-esr60+
QA Whiteboard: [qa-triaged]

Hello Bryce, I think I was a bit carried away when I flagged this as qe-verify+. At a closer look I am not entirely sure this is actually testable, but I might be wrong.

Flags: needinfo?(bvandyk)

This fallback downloader is only used when balrog isn't available. It could be tested by blocking access to our update servers and making sure we use the URL in the fallback file (which is the same as the update servers, so you'd need to verify that those requests were indeed blocked).

I don't think this is a high priority to test, as I believe balrog/the update servers have robust uptime. Please clear flags as appropriate.

Flags: needinfo?(bvandyk)

(In reply to Bryce Seager van Dyk (:bryce) from comment #14)

This fallback downloader is only used when balrog isn't available. It could be tested by blocking access to our update servers and making sure we use the URL in the fallback file (which is the same as the update servers, so you'd need to verify that those requests were indeed blocked).

I don't think this is a high priority to test, as I believe balrog/the update servers have robust uptime. Please clear flags as appropriate.

Thanks for your response Bryce!

QA Whiteboard: [qa-triaged]
Flags: qe-verify+
See Also: → 1596894
You need to log in before you can comment on or make changes to this bug.