Closed Bug 1566182 Opened 9 months ago Closed 9 months ago

Annotate mochitests that fail with Fission enabled

Categories

(Testing :: Mochitest, task, P2)

task

Tracking

(Fission Milestone:M4, firefox70 fixed)

RESOLVED FIXED
mozilla70
Fission Milestone M4
Tracking Status
firefox70 --- fixed

People

(Reporter: kmag, Assigned: kmag)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

This will allow us to enable running Fission mochitests on normal integration branches, and to see actual regressions from unexpected failures that would otherwise be lost in the noise.

The tests will be annotated with fail-if = fission annotations, which will need to be removed as soon as a test starts passing with Fission enabled so that it can't regress.

My preference was to annotate most of the failing tests with fail-if so that
if they start passing, the fail-if needs to be removed and they need to keep
passing. That doesn't work for tests that timeout, or which trigger failures
from their cleanup functions, however, so those tests need skip-if. And tests
with fail in their cleanup functions likely leave the browser in an
inconsistent state for subsequent tests, anyway, so really should be skipped
regardless.

There are some remaining tests which still fail because of crashes. I chose
not to skip them here, but to fix the crashes in separate bugs instead.

Fission Milestone: --- → M4
Priority: -- → P2
See Also: → 1566952
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
You need to log in before you can comment on or make changes to this bug.