Closed Bug 1566281 Opened 1 year ago Closed 1 year ago

Labels and input fields of Server settings having a gap

Categories

(MailNews Core :: Account Manager, defect, minor)

defect
Not set
minor

Tracking

(thunderbird68 fixed, thunderbird69 fixed, thunderbird70 fixed)

RESOLVED FIXED
Thunderbird 70.0
Tracking Status
thunderbird68 --- fixed
thunderbird69 --- fixed
thunderbird70 --- fixed

People

(Reporter: aceman, Assigned: Paenglab)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1565703 comment 18+++

After bug 1565703 solved to most urgent problems of hiding the AM fields, we can polish it now.

For movemail, when the port elements are hidden, there appears a big gap between the labels (first column) and the inputboxes (second column), probably because the both column of the grid expand to fill the 100% of the dialog width.
This is similar to what we had to fight with in bug 1561390, we need the first column to only fit the content width, and then the second column span the whole remaining width.

With setting max-content on the first column of the grid it doesn't expand when one column is hidden.

I also added the input[type="number"] width definitions.

Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #9078355 - Flags: review?(mkmelin+mozilla)
Comment on attachment 9078355 [details] [diff] [review]
1565703-AM-input-amServerSetting-fixes.patch

Review of attachment 9078355 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks, first column is minimized now.
The second column does not take the full remaining with (when the port is hidden), but that is not strictly necessary.
I see no change in appearance of input type="number".
Attachment #9078355 - Flags: review+
Comment on attachment 9078355 [details] [diff] [review]
1565703-AM-input-amServerSetting-fixes.patch

-
Attachment #9078355 - Flags: approval-comm-beta+
Attachment #9078355 - Flags: review?(mkmelin+mozilla) → review+

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/b865b8b9b3ed
Fix the input[type="number"] width in AM and make the first column of the amServerSetting smaller. r=aceman,mkmelin

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Keywords: checkin-needed
Resolution: --- → FIXED

_

Target Milestone: --- → Thunderbird 70.0
You need to log in before you can comment on or make changes to this bug.