Closed Bug 1566385 Opened 8 months ago Closed 7 months ago

Automatically update fennec-nightly-latest

Categories

(Release Engineering :: Release Automation: Bouncer, task)

task
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: jlorenzo, Assigned: mtabara)

References

Details

Attachments

(3 files)

In bug 1553396, I introduced a new bouncer location called fennec-nightly-latest. It needs to remain up to date every time we bump the minor version, otherwise bugs like bug 1565863 will be filed again.

:mtabara pointed out we can define a Fennec job like this one [1] and let bouncer allow this new alias[2]

[1] https://hg.mozilla.org/releases/mozilla-esr68/file/tip/taskcluster/ci/bouncer-locations/kind.yml#l42
[2] https://github.com/mozilla-releng/bouncerscript/blob/c22d5336c7afe4defcfa372007c3c7d79fdaae8a/bouncerscript/constants.py#L51

Assignee: nobody → mtabara

Note to self, for posterity: for testing, I've been using try pushes and pinning bouncer-dev environment. Triggered nightlies by using Johan's existing https://tools.taskcluster.net/hooks/garbage/jlorenzo-fennec-nightly-try pointed to my try submission.

Add bouncer-locations job in ESR Fennec nightlies

Attachment #9080623 - Attachment description: Bug 1566385 - add fennec bouncer-locations job for esr68. → Bug 1566385 - add fennec bouncer-locations job for esr68.r=jlorenzo a=release
Pushed by mtabara@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e8d6ff3d2aae
add fennec bouncer-locations job for esr68.r=jlorenzo a=release
Pushed by mtabara@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a6fa09658817
add product in bouncer-locations's payload. remove maple. r=jlorenzo

Mea culpa - the patch wasn't supposed to land on central; at least not all of it. I split it in two parts and landed it respectively to autoland for central and to esr68 - https://hg.mozilla.org/releases/mozilla-esr68/rev/ceaf54ecb17aec1658f68cfb86021a0be667c5e5

This is now done, closing the bug.

Status: NEW → RESOLVED
Closed: 7 months ago
Flags: needinfo?(mtabara)
Resolution: --- → FIXED
Duplicate of this bug: 1396945
You need to log in before you can comment on or make changes to this bug.