Closed Bug 1566604 Opened 1 year ago Closed 1 year ago

FireFox 69 scrolling and/or font rendering issue (see screenshot)

Categories

(Core :: Graphics: WebRender, defect, P3)

69 Branch
x86_64
Windows 10
defect

Tracking

()

RESOLVED DUPLICATE of bug 1566712
Tracking Status
firefox69 --- affected

People

(Reporter: zxspectrum3579, Unassigned)

References

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

Steps to reproduce:

Just browsing.

Actual results:

From time to time FireFox shrinks text vertically, skipping a few lines, during scrolling -- exactly at the very threshold between visible and not yet visible text if the users make a pause during the scrolling. The issue stays on until the user scrolls the part completely away up or down so the corrupted part would be re-rendered, and then it looks perfectly fine.

Expected results:

Perfectly accurate text at all times.

Component: Untriaged → Graphics: Text
OS: Unspecified → Windows 10
Product: Firefox → Core
See Also: → 1563983

Can you check the "Compositing" feature in about:support? Does it say "WebRender"?

Flags: needinfo?(zxspectrum3579)

Yes.

Flags: needinfo?(zxspectrum3579)

I forgot to add information that might be relevant: as you can see from the screenshot, my Windows 10 runs in graphics scaling mode (about 138% of versus 100% scale by default). This should not affect the issue of lines being skipped at the border of the "viewport" after scrolling is paused, but still.

So it looks like a couple of lines get either erased or duplicated at the border of the scrolling viewport.

I suspect this is a dup of bug 1565473

Depends on: 1565473
Component: Graphics: Text → Graphics: WebRender
Hardware: Unspecified → x86_64
Priority: -- → P3

Please leave a note or reopen this bug in case you see it again. I saw it on Reddit, but bug 1566712 fixed it.

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1566712
You need to log in before you can comment on or make changes to this bug.