Closed Bug 1566712 Opened 4 months ago Closed 4 months ago

Fix quality issues with picture caching when the transform has a fractional offset.

Categories

(Core :: Graphics: WebRender, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox69 --- fixed
firefox70 --- fixed

People

(Reporter: gw, Assigned: gw)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

No description provided.
Assignee: nobody → gwatson

This patch reverts the previous attempted fix for snapping issues
with picture caching, and implements a better solution.

This fixes the main visual issue by ensuring that any fractional
offset in the root transform is accounted for by:

  • Offsetting the tile rects by this amount, so that the content
    origin is a whole device pixel.
  • Invalidating all tiles if the fractional part of the root
    transform changes. This is required since it can affect the
    snapping logic that WR applies. Fortunately, this occurs
    very rarely - Gecko typically has a constant fractional part
    for each page.
Priority: -- → P3
Pushed by gwatson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a2fdbfed0d71
Fix quality issues with picture caching when the transform has a fractional offset. r=kvark
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
Regressions: 1567089
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: mozilla70 → ---

I'll investigate this today, and get it re-landed.

Even if I just comment out those debug asserts that are occurring on a couple of tests, this patch should still be a net improvement on what's currently in m-c. But I'll look into those test cases / platforms that hit the assert this morning, and see if I can work out what's going on first.

Flags: needinfo?(gwatson)

Rebased and updated patch to account for zoom factors in the root transform, which was causing a test failure on some platforms.

Pending try:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=11dc6dfe8a21404ef2858974e2f01bccfc53fc86

The try run looks good now, as far as I can tell.

Pushed by gwatson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5c6895ea59af
Fix quality issues with picture caching when the transform has a fractional offset. r=kvark
Status: REOPENED → RESOLVED
Closed: 4 months ago4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70

Comment on attachment 9078586 [details]
Bug 1566712 - Fix quality issues with picture caching when the transform has a fractional offset.

Beta/Release Uplift Approval Request

  • User impact if declined: Visual artifacts in text rendering on some platforms with WebRender on some pages.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This will fix some or all of these beta bugs for users with WR enabled:

https://bugzilla.mozilla.org/show_bug.cgi?id=1566178
https://bugzilla.mozilla.org/show_bug.cgi?id=1541072
https://bugzilla.mozilla.org/show_bug.cgi?id=1565473
https://bugzilla.mozilla.org/show_bug.cgi?id=1566517

  • String changes made/needed:
Attachment #9078586 - Flags: approval-mozilla-beta?

Comment on attachment 9078586 [details]
Bug 1566712 - Fix quality issues with picture caching when the transform has a fractional offset.

Fixes a number of text rendering bugs for users with WebRender enabled. Approved for 69.0b7.

Attachment #9078586 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Duplicate of this bug: 1566517
Duplicate of this bug: 1566604
Duplicate of this bug: 1565473
Duplicate of this bug: 1562874
You need to log in before you can comment on or make changes to this bug.