Closed Bug 1566714 Opened 1 year ago Closed 11 months ago

baidu.com clicking next page on search result won't return to the top

Categories

(Core :: Layout: Scrolling and Overflow, defect, P3)

68 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1568826
Tracking Status
firefox68 --- wontfix
firefox69 --- fixed
firefox70 --- fixed

People

(Reporter: yxu, Unassigned)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

STR:

  1. Create a new profile, open baidu.com.
  2. Search any word such as 'test' and click enter.
  3. On search result page, scroll down to the bottom, click '下一页' which means next page.
  4. You will see the page stay at the bottom. And it seems that there is a floating layer on the page. When the mouse hovers over any link, it will not be converted into a hand mark.

You can see the video shows what happend. Test in other browser it works fine. I made a regression test point to Bug 1549625. It may affect the internal implementation of jquery used by Baidu. Currently we can block all_async_search_*.js under ss1.bdstatic.com, and let Baidu return to the traditional full page refresh, there will be no such problem.

I am not sure if this change will affect other features of the page. Considering that Baidu is the most used website for Chinese people, we should probably try to solve it through a hotfix.

Attached video baidu search.mp4

If this is regressed by bug 1549625, hopefully bug 1543485 fixes this (I guess it should).

Depends on: 1543485
Priority: -- → P3

Does this still occur with latest nightly? I'm hoping it was fixed by bug 1568826.

Flags: needinfo?(yxu)

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:70.0) Gecko/20100101 Firefox/70.0 ID:20190807215212
Using this nightly version test and find that the issue has been fixed. Thanks Botond!

Flags: needinfo?(yxu)

Thanks! I'm marking this as a dupe of bug 1568826, and updating status flags to indicate that the fix has been backported to 69 as well.

Status: NEW → RESOLVED
Closed: 11 months ago
No longer depends on: 1543485
Resolution: --- → DUPLICATE
Duplicate of bug: 1568826
You need to log in before you can comment on or make changes to this bug.