Closed Bug 1566786 Opened 2 years ago Closed 2 years ago

Entering Customize menu while reload button is in transition makes the icon disappear

Categories

(Firefox :: Toolbars and Customization, defect, P3)

defect

Tracking

()

VERIFIED FIXED
Firefox 75
Tracking Status
firefox-esr68 --- wontfix
firefox68 --- wontfix
firefox69 --- wontfix
firefox70 --- wontfix
firefox73 --- wontfix
firefox74 --- wontfix
firefox75 --- verified

People

(Reporter: atrif, Assigned: Gijs)

Details

(Keywords: regression)

Attachments

(3 files)

Attached image reload_button.gif

Affected versions

  • Firefox 68.0 (20190705220548)
  • Firefox 69.0b5 (20190715173502)
  • Firefox 70.0a1 (20190711230342)

Affected platforms

  • Ubuntu 16.04
  • macOS 10.14
  • Windows 10x64
  • Windows 7x64

Steps to reproduce

  1. Launch Firefox and go to a random website.
  2. While the website is loading enter Customize menu or reload the webpage and try again.

Expected result

  • Reload button remains the same after entering the Customize menu.

Actual result

  • When entering customize menu at the right time the Reload button icon is erased.

Regression Range

  • Reproducible with Firefox 67.0a1 (20190202213603). I will search for one ASAP.

Additional Notes

  • Placing the Reload button on the tab bar after being erased makes the button invisible until reuse.
  • Setting the Reload button on the tab bar and changing tabs from Customize to a random one makes the icon automatically appear.
  • It's an edge case issue and it's hard to reproduce because of the correct timing when entering Customize menu.
  • Attached a screen recording with the issue.
Has Regression Range: --- → no
Has STR: --- → yes

Bugbug thinks this bug is a regression, but please revert this change in case of error.

Keywords: regression

Hello,
Here the regression range:
Last good revision: fa1da3c0b200abbd9cfab3cab19962824314044e (2017-08-03)
First bad revision: 4cfb674227051e22bab651e5759f3de503a50560 (2017-08-04)
Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=fa1da3c0b200abbd9cfab3cab19962824314044e&tochange=4cfb674227051e22bab651e5759f3de503a50560
Thank you!

Has Regression Range: no → yes
Flags: needinfo?(gijskruitbosch+bugs)

I think some of Dão's recent refactors here may have made this go away - I can't reproduce anymore. Can you still reproduce, and if so, can you provide more accurate steps?

Flags: needinfo?(gijskruitbosch+bugs) → needinfo?(alexandru.trif)

(In reply to :Gijs (he/him) from comment #3)

I think some of Dão's recent refactors here may have made this go away - I can't reproduce anymore. Can you still reproduce, and if so, can you provide more accurate steps?

I can still reproduce the issue with Firefox 73.0 (20200207195153), Firefox 74.0b4 (20200216164042) and Firefox 75.0a1 (20200216210001). Marking those as affected.

For STR I used the following (note that sometimes this needs several tries to actually reproduce it, and timing):

  1. Go to https://www.youtube.com/ and wait for the page to load.
  2. Press the refresh button and right-click on the address bar to open the context menu.
  3. Wait for the reload button transition (when the page it's almost loaded) and click on the "Customize" context menu option. This needs to be done while reload button it's changing state from "X" to refresh arrow. Made a screen recording for better understanding.
Flags: needinfo?(alexandru.trif)
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/07c0afec88a6
don't leave stop/reload button without an icon if the animation gets cancelled, r=dao
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 75

Verified fixed using Firefox 75.0b11 (20200328010112) on Windows 10x64, macOS 10.12 and Ubuntu 18.04.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.