[RFE] Priority setting for Tasks

RESOLVED FIXED

Status

Calendar
Sunbird Only
--
enhancement
RESOLVED FIXED
16 years ago
12 years ago

People

(Reporter: ajbu, Assigned: Mike Potter)

Tracking

Details

Attachments

(3 attachments)

(Reporter)

Description

16 years ago
oeIICalTodo/oeIICalEvent in CVS now has a 'priority' attribute, so it can be 
linked to the frontend.

I found the following code in calendarToDoDialog.xul:

                    <!-- Priority -->    
                    <row align="center" collapsed="true">
                        <hbox class="field-label-box-class" pack="end">
                            <label value="&newtodo.priority.label;"/>
                        </hbox>
                        <menulist>
                          <menupopup>
                              <menuitem label="1" value="1"/>
                              <menuitem label="2" value="2"/>
                              <menuitem label="3" value="3"/>
                              <menuitem label="4" value="4"/>
                              <menuitem label="5" value="5"/>
                          </menupopup>
                        </menulist>
                    </row>


The RFC defines priority as between 1 and 9, 1 the highest priority.
The tree-level priority scheme with HIGH/MEDIUM/LOW settings seems to be more 
useful to me.
This defines that 'low' is mapped on a PRIORITY between 1 and 4, PRIORITY=5 
means 'medium', and a value frorm 6 to 9 is used for 'high'

This could give something like:
                          <menupopup>
                              <menuitem label="&newtodo.priority.low.label;" 
value="9"/>
                              <menuitem 
label="&newtodo.priority.medium.label;" value="5"/>
                              <menuitem label="&newtodo.priority.high.label;" 
value="1"/>
                          </menupopup>
(Reporter)

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 1

16 years ago
Created attachment 92720 [details] [diff] [review]
Adds new properties to tasks

- Priorities: Menulist with None, Low, Medium, High
Not sure about the None(no priority is set), might be dropped and use Medium as
default.

- Percent complete: Can set a % between 0 and 100. Setting 100 checks the
completed checkbox

- Categories: Menulist with default categories from categories.properties. Code
to edit the categories list not yet complete.

- Status: Status property is also stored, depending on completed/percent
compete status.
(Assignee)

Comment 2

16 years ago
I'll check this in. The only comment I have is that I absolutely hate the use of
min-width in XUL elements, and also that I didn't think it was a valid XUL
attribute, it should be style="min-width: 120px;" (again though, I absolutely
dispise the use of min width, since it can mess up system with really small fonts).
Status: NEW → ASSIGNED
(Reporter)

Comment 3

16 years ago
Created attachment 92722 [details]
local/en-US/categories.properties

Did forget the properties.
(Reporter)

Comment 4

16 years ago
Created attachment 92744 [details] [diff] [review]
patch for default categories

When importing events that already have categories, those get lost because the
current categories field is a fixed list. Patch adds the existing category to
the list and selects it.
Also fixes a value I had changed for debugging
(Assignee)

Comment 5

16 years ago
Checked into cvs.
(Assignee)

Comment 6

16 years ago
This is all checked in, marking fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 7

15 years ago
[RFE] is deprecated in favor of severity: enhancement.  They have the same meaning.
Severity: normal → enhancement
The bugspam monkeys have been set free and are feeding on Calendar :: Sunbird Only. Be afraid for your sanity!
QA Contact: colint → sunbird
You need to log in before you can comment on or make changes to this bug.