Closed Bug 1566903 Opened 2 months ago Closed 2 months ago

cmd+f should re-select the searchbar query

Categories

(DevTools :: Debugger, enhancement, P3)

enhancement

Tracking

(firefox70 fixed)

RESOLVED FIXED
Firefox 70
Tracking Status
firefox70 --- fixed

People

(Reporter: jlast, Assigned: khmorehouse)

References

(Blocks 1 open bug)

Details

(Keywords: good-first-bug)

Attachments

(1 file)

I've noticed that in editors cmd+f will always re-focus and select the searchbar text. This is useful when you're jumping between search results and want to quickly make changes in the searchbar. It is also a common convention that we should maintain.

Keywords: good-first-bug

I'd like to take this one, Jason.

Assignee: nobody → khmorehouse
Priority: -- → P3
Duplicate of this bug: 1566902

Jason, I'd like to zero-in on an accurate STR for this bug. Is the following one correct?

Steps to Reproduce:

  1. Navigate to http://todomvc.com/examples/backbone/
  2. Open the debugger
  3. Click the file todomvc.com/examples/backbone/js/collections/todos.js under the Sources tab in the left sidebar
  4. Hit Cmd + F (or Ctrl+F on Windows)
  5. Type "collection"
  6. Hit Cmd + F (or Ctrl+F on Windows).

Expected Result:

  • The query "collection" in the search bar should now be highlighted.

Actual Result:

  • The query "collection" in the search bar is not highlighted.
Flags: needinfo?(jlaster)

yep

Flags: needinfo?(jlaster)

This patch ensures that any existing query text in the search bar is highlighted when the Cmd/Ctrl + F shortcut is used.

Pushed by jlaster@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/af933062446a
Work-in-Progress Patch - Ensure that Ctrl/Cmd + F shortcut always re-selects the search bar query. r=jlast
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70
You need to log in before you can comment on or make changes to this bug.