Closed Bug 1567093 Opened 5 months ago Closed 5 months ago

Crash present when accessing Fennec without no internet connection.

Categories

(Firefox for Android :: First Run, defect)

Firefox 68
ARM
Android
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1562622
Tracking Status
firefox-esr68 --- fixed

People

(Reporter: diana.rus, Assigned: petru)

References

(Regression)

Details

Environment
Device: Samsung Galaxy S9 (Android 8.0.0)
Build: Fennec Beta 68.1b2

Prerequisites:

  • Wi-fi is disabled/No internet connection available.

Steps to reproduce:

  1. Clear Data for Fennec from device's Settings/Apps/Firefox Beta/Storage.
  2. Open Fennec.

Expected Result: The Welcome Screens: Welcome, Privacy and Account are displayed. After tapping on "Start browsing" the panels: Top Site, Bookmarks and History are displayed.

Actual Result: Crash present.

NOTE: Please see crash report: https://crash-stats.mozilla.com/report/index/167126e1-7c42-45e9-bccf-591660190718#tab-details .
Crash Signature:

  • java.lang.IllegalStateException: at android.view.ViewTreeObserver.checkIsAlive(ViewTreeObserver.java)

Build ID:

  • 20190715205913

Java Stack Trace:

  • java.lang.IllegalStateException
    at android.view.ViewTreeObserver.checkIsAlive(ViewTreeObserver.java:918)
    at android.view.ViewTreeObserver.removeOnGlobalLayoutListener(ViewTreeObserver.java:611)
    at org.mozilla.gecko.home.TabMenuStripLayout$1.onGlobalLayout(TabMenuStripLayout.java:133)
    at android.view.ViewTreeObserver.dispatchOnGlobalLayout(ViewTreeObserver.java:1013)
    at android.view.ViewRootImpl.performTraversals(ViewRootImpl.java:2679)
    at android.view.ViewRootImpl.doTraversal(ViewRootImpl.java:1779)
    at android.view.ViewRootImpl$TraversalRunnable.run(ViewRootImpl.java:7810)
    at android.view.Choreographer$CallbackRecord.run(Choreographer.java:911)
    at android.view.Choreographer.doCallbacks(Choreographer.java:723)
    at android.view.Choreographer.doFrame(Choreographer.java:658)
    at android.view.Choreographer$FrameDisplayEventReceiver.run(Choreographer.java:897)
    at android.os.Handler.handleCallback(Handler.java:789)
    at android.os.Handler.dispatchMessage(Handler.java:98)
    at android.os.Looper.loop(Looper.java:164)
    at android.app.ActivityThread.main(ActivityThread.java:6938)
    at java.lang.reflect.Method.invoke(Native Method)
    at com.android.internal.os.Zygote$MethodAndArgsCaller.run(Zygote.java:327)
    at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:1374)

Looking through the code of the build in which this crash happened
https://hg.mozilla.org/releases/mozilla-esr68/file/b4d4b2c7e36946690af1b59668cc2534c36b2f0d/mobile/android/base/java/org/mozilla/gecko/home/TabMenuStripLayout.java#l133
it seems that this should've been fixed by the patch from bug 1562622 for which an uplift is pending.

Assignee: nobody → petru.lingurar
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1562622
You need to log in before you can comment on or make changes to this bug.