Closed Bug 1567095 Opened 1 year ago Closed 1 year ago

Add New Address popup field name texts have broken styles

Categories

(Firefox :: Preferences, defect, P1)

69 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 + verified
firefox70 + verified

People

(Reporter: pciapa, Assigned: Gijs)

References

(Regression)

Details

(Keywords: regression)

Attachments

(4 files)

Attached image osx.png

Add New Address popup field name texts have broken styles on OSX and margin is different on Windows and Linux

First name, Middle name, Last name are cutted in top

City, Zip Code, Organization are back to back to field's border and
margins are different as in Windows and Linux.

Attached image win10.png

Is this a recent regression? Are you testing Nightly or another version? What are the steps to reproduce?

Flags: needinfo?(pciapa)

This is recent regression
version 69 0b5
->about:preferences -> Forms and Autofill -> Saved Addresses... -> Add...

Flags: needinfo?(pciapa)

Due to new Mozilla's privacy you also need to set 'browser.search.region', 'US', in some countries to have this feature on

(In reply to pciapa from comment #3)

This is recent regression
version 69 0b5
->about:preferences -> Forms and Autofill -> Saved Addresses... -> Add...

Can you find a regression window? Is nightly also affected?

Flags: needinfo?(pciapa)

I can reproduce this on Nightly.

Bug 1553373 is the regressor.

Hey dao, I think jaws is pretty heads down on Lockwise stuff right now... do you have time to look at this?

Blocks: 1553373
Flags: needinfo?(pciapa) → needinfo?(dao+bmo)

As for step to reproduce:
Preconditions

Beta:

  • extensions.formautofill.available set to "on"./extensions.formautofill.creditCards.available;true/extensions.formautofill.creditCards.enabled;true
  • Go to Preferences(Options)/ Privacy and Security / Form Autofill / Enable Saved Credit Cards
  • Make sure you have at least one saved Credit Card information.

Note: Form autofill is enabled by default in Nightly.

as for regression window - asked from my manual testers colleagues who have this zone of responsibility. But I see that you already found it

Flags: needinfo?(dao+bmo)

:pciapa, since this bug is a regression, could you fill (if possible) the regressed_by field?
For more information, please visit auto_nag documentation.

Flags: needinfo?(pciapa)
No longer blocks: 1553373
Flags: needinfo?(pciapa)
Regressed by: 1553373

[Tracking Requested - why for this release]:
User-visible regression in 69 that we can probably still avoid shipping with a low-risk CSS patch.

Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Priority: -- → P1
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/5fa220bc8882
fix styling of address inputs in preferences, r=dao

Comment on attachment 9080279 [details]
Bug 1567095 - fix styling of address inputs in preferences, r?dao

Beta/Release Uplift Approval Request

  • User impact if declined: Broken styling for form autofill
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: See other comments in this bug.
  • List of other uplifts needed: n/a
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): 1-rule CSS patch specific to the broken stuff here to fix the regression.

(Requesting approval early as I'm on PTO for 2 weeks from tomorrow.)

  • String changes made/needed: nope
Attachment #9080279 - Flags: approval-mozilla-beta?
Flags: qe-verify+
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70
QA Whiteboard: [qa-triaged]

Verified on Windows 10 x64 and MacOS 10.12 with Nightly 70.0a1 and while the address text fields look ok, the credit card pop up field name text does not look fixed. Please see the new attachment for macOS.

Let me know if we should file a separate issue for this.

Flags: needinfo?(gijskruitbosch+bugs)

(In reply to Gabi Cheta [:Gabi] Release Desktop QA from comment #15)

Verified on Windows 10 x64 and MacOS 10.12 with Nightly 70.0a1 and while the address text fields look ok, the credit card pop up field name text does not look fixed. Please see the new attachment for macOS.

Let me know if we should file a separate issue for this.

Yes, please file a separate issue and request tracking for 69 + 70 as appropriate.

Flags: needinfo?(gijskruitbosch+bugs) → needinfo?(gasofie)

Comment on attachment 9080279 [details]
Bug 1567095 - fix styling of address inputs in preferences, r?dao

Form autofill styling improvement. Approved for 69.0b9.

Attachment #9080279 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Verified as fixed with 69.0b9 and Nightly 70.0a1 on Windows 10x64, Ubuntu 16.04 and MacOS 10.12.
Opened 1569963 for the Edit Credit Card fields issue.

Flags: needinfo?(gasofie)
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.