Closed Bug 1567153 Opened 9 months ago Closed 4 months ago

Assertion failure: inits.Length() == mContexts.Count() (Visited the wrong number of contexts!), at docshell/base/BrowsingContextGroup.cpp:89

Categories

(Core :: DOM: Content Processes, defect, P3)

defect

Tracking

()

RESOLVED WORKSFORME
Fission Milestone M5
Tracking Status
firefox72 --- ?

People

(Reporter: jya, Unassigned, NeedInfo)

References

(Blocks 2 open bugs)

Details

Visiting a CNN article lead to:

Assertion failure: inits.Length() == mContexts.Count() (Visited the wrong number of contexts!), at c:/Users/jyavenard/Work/Mozilla/gecko/docshell/base/BrowsingContextGroup.cpp:89
#01: mozilla::dom::BrowserBridgeParent::Init (c:\Users\jyavenard\Work\Mozilla\gecko\dom\ipc\BrowserBridgeParent.cpp:64)
#02: mozilla::dom::BrowserParent::RecvPBrowserBridgeConstructor (c:\Users\jyavenard\Work\Mozilla\gecko\dom\ipc\BrowserParent.cpp:1247)
#03: mozilla::dom::PBrowserParent::OnMessageReceived (c:\Users\jyavenard\Work\Mozilla\obj-ff-dbg\ipc\ipdl\PBrowserParent.cpp:2793)
#04: mozilla::dom::PContentParent::OnMessageReceived (c:\Users\jyavenard\Work\Mozilla\obj-ff-dbg\ipc\ipdl\PContentParent.cpp:5565)
#05: mozilla::ipc::MessageChannel::DispatchAsyncMessage (c:\Users\jyavenard\Work\Mozilla\gecko\ipc\glue\MessageChannel.cpp:2168)
#06: mozilla::ipc::MessageChannel::DispatchMessage (c:\Users\jyavenard\Work\Mozilla\gecko\ipc\glue\MessageChannel.cpp:2089)
#07: mozilla::ipc::MessageChannel::RunMessage (c:\Users\jyavenard\Work\Mozilla\gecko\ipc\glue\MessageChannel.cpp:1940)
#08: mozilla::ipc::MessageChannel::MessageTask::Run (c:\Users\jyavenard\Work\Mozilla\gecko\ipc\glue\MessageChannel.cpp:1971)
#09: nsThread::ProcessNextEvent (c:\Users\jyavenard\Work\Mozilla\gecko\xpcom\threads\nsThread.cpp:1227)
#10: NS_ProcessNextEvent (c:\Users\jyavenard\Work\Mozilla\gecko\xpcom\threads\nsThreadUtils.cpp:486)
#11: mozilla::ipc::MessagePump::Run (c:\Users\jyavenard\Work\Mozilla\gecko\ipc\glue\MessagePump.cpp:88)
#12: MessageLoop::RunInternal (c:\Users\jyavenard\Work\Mozilla\gecko\ipc\chromium\src\base\message_loop.cc:315)
#13: MessageLoop::RunHandler (c:\Users\jyavenard\Work\Mozilla\gecko\ipc\chromium\src\base\message_loop.cc:309)
#14: MessageLoop::Run (c:\Users\jyavenard\Work\Mozilla\gecko\ipc\chromium\src\base\message_loop.cc:291)
#15: nsBaseAppShell::Run (c:\Users\jyavenard\Work\Mozilla\gecko\widget\nsBaseAppShell.cpp:139)
#16: nsAppShell::Run (c:\Users\jyavenard\Work\Mozilla\gecko\widget\windows\nsAppShell.cpp:412)
#17: nsAppStartup::Run (c:\Users\jyavenard\Work\Mozilla\gecko\toolkit\components\startup\nsAppStartup.cpp:276)
#18: XREMain::XRE_mainRun (c:\Users\jyavenard\Work\Mozilla\gecko\toolkit\xre\nsAppRunner.cpp:4636)
#19: XREMain::XRE_main (c:\Users\jyavenard\Work\Mozilla\gecko\toolkit\xre\nsAppRunner.cpp:4771)
#20: XRE_main (c:\Users\jyavenard\Work\Mozilla\gecko\toolkit\xre\nsAppRunner.cpp:4852)
#21: mozilla::BootstrapImpl::XRE_main (c:\Users\jyavenard\Work\Mozilla\gecko\toolkit\xre\Bootstrap.cpp:45)
#22: do_main (c:\Users\jyavenard\Work\Mozilla\gecko\browser\app\nsBrowserApp.cpp:213)
#23: NS_internal_main (c:\Users\jyavenard\Work\Mozilla\gecko\browser\app\nsBrowserApp.cpp:295)
#24: wmain (c:\Users\jyavenard\Work\Mozilla\gecko\toolkit\xre\nsWindowsWMain.cpp:131)
#25: invoke_main (d:\agent_work\2\s\src\vctools\crt\vcstartup\src\startup\exe_common.inl:91)
#26: __scrt_common_main_seh (d:\agent_work\2\s\src\vctools\crt\vcstartup\src\startup\exe_common.inl:288)
#27: __scrt_common_main (d:\agent_work\2\s\src\vctools\crt\vcstartup\src\startup\exe_common.inl:331)
#28: wmainCRTStartup (d:\agent_work\2\s\src\vctools\crt\vcstartup\src\startup\exe_wmain.cpp:17)
#29: BaseThreadInitThunk[C:\WINDOWS\System32\KERNEL32.DLL +0x17bd4]
#30: RtlUserThreadStart[C:\WINDOWS\SYSTEM32\ntdll.dll +0x6ce71]

Here we had init.Length == 2 and mContexts.Count == 3

Flags: needinfo?(afarre)
Priority: -- → P3

Tentatively moving all bugs whose summaries mention "Fission" (or other Fission-related keywords) but are not assigned to a Fission Milestone to the "?" triage milestone.

This will generate a lot of bugmail, so you can filter your bugmail for the following UUID and delete them en masse:

0ee3c76a-bc79-4eb2-8d12-05dc0b68e732

Fission Milestone: --- → ?
Fission Milestone: ? → M5

Jean-Yves, can you still reproduce this assertion failure on CNN?

Flags: needinfo?(jyavenard)

Haven't been able to reproduce that bug since DC has landed.

Status: NEW → RESOLVED
Closed: 4 months ago
Flags: needinfo?(jyavenard)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.