Return key does not appear to work when using formatted text (caret doesn't move down a line)

VERIFIED WORKSFORME

Status

()

Core
Editor
VERIFIED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Joel Nelson (don't send email), Assigned: Joe Francis)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: EDITORBASE)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.1a+) Gecko/20020702
BuildID:    2002070203

When I specify a font for a web page or e-mail message, if I press the Return
key at the end of a line, the cursor does not advance to the next line.  If I
begin typing, then the cursor will advance.   If I press return a second time,
then the cursor advances one line but when I start typing, the text is
double-spaced. 

Reproducible: Always
Steps to Reproduce:
1. Select a font in Composer
2. Type a line of text
3. Press return

Actual Results:  Nothing happened until I began typing the text for the next line.

Expected Results:  The flashing cursor should have advanced.

I don't know if it's related or not, but I can't use Backspace to move the
cursor up a line or two if I'm using formatted text.   This seems to be a
regression.

Comment 1

16 years ago
-->jfrancis
 (maybe this is a dupe of a bug already fixed?)

nominate for editorbase since the caret doesn't go where the text will be put
which is very confusing/disconcerting
Assignee: syd → jfrancis
Component: Editor: Composer → Editor: Core
Keywords: nsbeta1
Summary: Return key does not appear to work when using formatted text → Return key does not appear to work when using formatted text (caret doesn't move down a line)
Whiteboard: EDITORBASE
WFM: 10/24/2002 build on W2K.
Resolving WFM.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 3

16 years ago
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.