Closed Bug 1567298 Opened 4 months ago Closed 4 months ago

high contrast mode requires restart to take effect for content

Categories

(Core :: CSS Parsing and Computation, defect, P3)

Desktop
Windows
defect

Tracking

()

VERIFIED FIXED
mozilla70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- verified
firefox68 --- wontfix
firefox69 --- verified
firefox70 --- verified

People

(Reporter: asa, Assigned: emilio)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Until recently, one only needed to do a refresh to web content to get it to pick up changed Windows High Contrast settings. Starting on March 7's Nightly build, one needs to restart the browser to get content to pick up high contrast settings changes.

Steps to reproduce:

  1. Open Firefox and load a web page
  2. Turn on High Contrast mode in Windows settings
  3. Refresh the Firefox web page

Results: the page does not switch to high contrast mode until you restart the browser.

Expected results: the page switches to high contrast mode when you refresh.

Mozregression results:
build_url: https://queue.taskcluster.net/v1/task/BivX75MZSfGQ4pkm_H9zGQ/runs/0/artifacts/public%2Fbuild%2Ftarget.zip
changeset: 4a50be47adebd4c8f4fd2fb0171aa0c40d611921
pushlog_url: https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=4a50be47adebd4c8f4fd2fb0171aa0c40d611921&tochange=2e2dd6d6d5762cd5a60acdb1f14efadf76dcf490

Tested on Windows10 64bit:

nightly 70.0a1 >Reproducible
beta 69.0b7 >Reproducible
release 68.0.1 >Reproducible

Component: Untriaged → Graphics
Product: Firefox → Core

Tested on Ubuntu 18.04.2 64bit

nightly 70.0a1 >Reproducible
beta 69.0b7 >Reproducible
release 68.0.1 >Reproducible

MacOs does not seem to be affected by this problem. Tested Macos "invert colors" setting.

nightly 70.0a1 > Not Reproducible
beta 69.0b7 > Not Reproducible
release 68.0.1 > Not Reproducible

OS: Unspecified → Windows
Hardware: Unspecified → Desktop
Component: Graphics → CSS Parsing and Computation
Priority: -- → P3
Regressed by: 1530193

So as to grab updated high contrast settings and co.

Assignee: nobody → emilio
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c46264666567
Refresh preference sheet data from ThemeChanged(). r=heycam
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70

Please nominate this for Beta and ESR68 approval when you get a chance.

I'd like to get it verified on Windows first, since I'm on Linux :)

Could someone confirm it works on a central build? (I'm not sure if it has made it to current nightly)

It should be in the latest Nightly builds, yes.

Comment on attachment 9080131 [details]
Bug 1567298 - Refresh preference sheet data from ThemeChanged(). r=#style

Beta/Release Uplift Approval Request

  • User impact if declined: Toggling high contrast would require a restart
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: comment 0
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): One-liner invalidating the high contrast rendering bit when it may have changed.
  • String changes made/needed: none
Flags: needinfo?(emilio)
Attachment #9080131 - Flags: approval-mozilla-beta?
Flags: qe-verify+

I verified myself on windows that now we properly switch.

Comment on attachment 9080131 [details]
Bug 1567298 - Refresh preference sheet data from ThemeChanged(). r=#style

ESR Uplift Approval Request

  • If this is not a sec:{high,crit} bug, please state case for ESR consideration: see above
  • User impact if declined: see above
  • Fix Landed on Version: 70
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): one liner, see above
  • String or UUID changes made by this patch: none
Attachment #9080131 - Flags: approval-mozilla-esr68?

Comment on attachment 9080131 [details]
Bug 1567298 - Refresh preference sheet data from ThemeChanged(). r=#style

Fixes a regression causing High Contrast mode to not take effect until the browser restarts. Approved for 68.0b9 and 68.1esr.

Attachment #9080131 - Flags: approval-mozilla-esr68?
Attachment #9080131 - Flags: approval-mozilla-esr68+
Attachment #9080131 - Flags: approval-mozilla-beta?
Attachment #9080131 - Flags: approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

Hello,

I can confirm that this issue is fixed on Fx 69.0b8, Fx 70.0a1 BuildID: 20190726094308 and Fx 68.0.1esr treeherder build (https://treeherder.mozilla.org/#/jobs?repo=mozilla-esr68&selectedJob=258387650).

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.