Closed Bug 1567371 Opened 2 months ago Closed 2 months ago

Proxy Connection setting Ok button not visible

Categories

(Thunderbird :: Preferences, defect)

defect
Not set

Tracking

(thunderbird_esr68 fixed, thunderbird69 fixed, thunderbird70 fixed)

VERIFIED FIXED
Thunderbird 70.0
Tracking Status
thunderbird_esr68 --- fixed
thunderbird69 --- fixed
thunderbird70 --- fixed

People

(Reporter: jaise, Assigned: Paenglab)

References

Details

Attachments

(3 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

In Proxy Connection setting Ok/Cancel button not visible in wide screen monitor[pic attached]. also attached Firefox connection setting picture.

Assignee: nobody → richard.marti
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #9079413 - Flags: review?(jorgk)
Attachment #9079413 - Flags: approval-comm-esr68?
Attachment #9079413 - Flags: approval-comm-beta?

Hmm, this still doesn't look good. The subdialogue is very high and I didn't see the buttons at first. There's a lot of empty space above the buttons, under the "DNS over HTTP" popup. BTW, that's empty here, in the reporters pictures I can see "Cloudflare (Default)".

The space above is for the textfield when you select Custom in the menulist. On Beta it works, it seems the prefs reordering broke the menulist.

Make the TB window only 500px tall and see the difference with and without the patch.

Comment on attachment 9079413 [details] [diff] [review]
1567371-subdialog-scrollbar.patch

OK, thanks. Please file a bug for the broken "DNS over HTTP".
Attachment #9079413 - Flags: review?(jorgk)
Attachment #9079413 - Flags: review+
Attachment #9079413 - Flags: approval-comm-esr68?
Attachment #9079413 - Flags: approval-comm-esr68+
Attachment #9079413 - Flags: approval-comm-beta?
Attachment #9079413 - Flags: approval-comm-beta+

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/183d48f45b75
Port bug 1493844, subdialogs.js part, to fix connection settings subdialog. r=jorgk

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 70.0

Why the change in connection.js?

Damn, I was trying to look at bug 1567622 and that change slipped it, grrr. I did a local hg qref to update the commit message :-(

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/e94d7ea656dc
Follow-up: Revert hunk that was added accidentally. r=me DONTBUILD

UPLIFT REMINDER: Merge both changesets or use original patch.

Working in TB 69 beta.

Status: RESOLVED → VERIFIED
Duplicate of this bug: 1570218
You need to log in before you can comment on or make changes to this bug.