Closed Bug 1567420 Opened 4 months ago Closed 4 months ago

opening searchbar drop down menu from magnifying glass broken if searchbar in overflow menu, clicking shows UI for a split second and closes overflow menu

Categories

(Firefox :: Toolbars and Customization, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 + verified
firefox70 + verified

People

(Reporter: aryx, Assigned: ntim)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Firefox 70.0a1 and 69.0 beta on Windows 8.1

This is a regression from bug 1556561.

Opening the searchbar drop down menu from the magnifying glass is broken if the searchbar is in the overflow menu. Clicking it shows the UI for a split second and closes the overflow menu.

Expected: Full UI with e.g. icons for other search engines shown.

Steps to reproduce:

  1. Open Firefox.
  2. Open its Options/Preferences, e.g. from the button with the 3 horizontal lines on the right of the toolbar.
  3. Go to 'Search'
  4. Change the setting to use a separate searchbar.
  5. Customize the toolbar (right-click > Customize).
  6. Drag and drop the searchbar into the the overflow menu.
  7. Exit Customize mode.
  8. Open the overflow menu.
  9. Move the mouse over the magnifying glass and notice the dropdown.
  10. Click it.

Actual result: Full searchbar UI shown for a split second, then overflow menu closed.

Expected result: Searchbar UI with all installed search engines shown.

Flags: needinfo?(ntim.bugs)
Flags: needinfo?(ntim.bugs)
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/06d634849449
Fix interactive element check in CustomizableUI.jsm. r=dao
Assignee: nobody → ntim.bugs

Comment on attachment 9079469 [details]
Bug 1567420 - Fix interactive element check in CustomizableUI.jsm. r=dao

Beta/Release Uplift Approval Request

  • User impact if declined: Searchbar autocomplete can't be opened from the search button when placed in the overflow panel
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: See comment 0
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): One line JS change
  • String changes made/needed: no
Attachment #9079469 - Flags: approval-mozilla-beta?
Flags: qe-verify+
Component: XUL Widgets → Toolbars and Customization
Product: Toolkit → Firefox
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70

Hello!
Reproduced the issue using Firefox 70.0a1 (20190719215614) on Windows 10x64,macOS 10.14, Ubuntu 18.04.
The issue is verified fixed with Firefox 70.0a1 (20190721215935) on Windows 10x64, Windows 8.1x64, macOS 10.14 and Ubuntu 18.04.

OS: Unspecified → All
Hardware: Unspecified → All

Comment on attachment 9079469 [details]
Bug 1567420 - Fix interactive element check in CustomizableUI.jsm. r=dao

Fixes searchbar autocomplete not being able to be opened from the search button when it's placed in the overflow panel. Approved for 69.0b7.

Attachment #9079469 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Hello!
The issue is verified fixed with Firefox 69.0b7 (20190722201635) on Windows 10x64, macOS 10.14 and Ubuntu 18.04.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.