Closed Bug 1567422 Opened 2 years ago Closed 2 years ago

"Tracking Protections" icon doesn't have hovering tooltip in some cases

Categories

(Firefox :: Site Identity, defect, P1)

70 Branch
x86_64
Windows 7
defect

Tracking

()

VERIFIED FIXED
Firefox 70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 --- unaffected
firefox70 --- verified

People

(Reporter: Virtual, Assigned: timhuang)

References

(Blocks 1 open bug)

Details

(4 keywords, Whiteboard: [skyline])

Attachments

(5 files)

Attached image bug.png

STR:

  1. Open this website page - https://hg.mozilla.org/
  2. Hover pointer/mouse cursor over "Tracking Protections" menu
    and see that it doesn't have hovering tooltip

:Virtual, if you think that's a regression, then could you try to find a regression range in using for example mozregression?

Bugbug thinks this bug is a regression, but please revert this change in case of error.

Keywords: regression
Whiteboard: [privacy-panel][triage]
Priority: -- → P1
Whiteboard: [privacy-panel][triage] → [skyline]

We should also fix the label for accessibility here. see Bug 1552716 comment 1.

Assignee: nobody → tihuang
Status: NEW → ASSIGNED

Hi Jamie,

I have a question about the accessibility of the tracking protection icon. IIUC, we don't need the 'aria-label' if we have a tooltip text on the tracking protection icon unless we want to show something else other than the tooltip text. Is that correct?

Flags: needinfo?(jteh)

Quickly filling in for Jamie here: That is correct. aria-label is only needed if this should be different from the tooltiptext. You can check what gets exposed as the accessible name by using the Accessibility Inspector in the Browser Toolbox and inspecting the accessibility tree of the button. The Name property is what you're looking for.

Flags: needinfo?(jteh)

The patch removes the old string of the tooltip on the trakcing
protection icon and replace them with the new strings.

This patch modify the way how tooltip works on the tracking protection
icon. We use <tooltip> instead of 'tooltiptext' attribute in order to
limit the width of the tooltip in 500px.

Depends on D40415

Set the 'aria-label' to the tracking protection icon container in order
to support the accessibility. We need this here since the accessiblity
won't automatically get the <tooltip> element here,

Depends on D40416

Attachment #9082597 - Attachment description: Bug 1567422 - Part 1: Remove the old tooltip strings and rename the new tooltop strings r?johannh!,flod! → Bug 1567422 - Part 1: Remove the old tooltip strings. r?johannh!,flod!
Pushed by tihuang@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1284a6b493d9
Part 1: Remove the old tooltip strings. r=johannh,flod
https://hg.mozilla.org/integration/autoland/rev/788a0b069454
Part 2: Update the tooltip of the tracking protection icon. r=johannh
https://hg.mozilla.org/integration/autoland/rev/249534a19058
Part 3: Add support of the accessibility for the tracking protection icon tooltip. r=johannh
https://hg.mozilla.org/integration/autoland/rev/c6594cf68af6
Part 4: Update tests. r=johannh

I'm confirming that bug is fixed, starting in Mozilla Firefox Nightly 70.0a1 (2019-08-07), so I'm marking this bug as VERIFIED.
Thank you very much! \o/

Status: RESOLVED → VERIFIED
Summary: "Tracking Protections" doesn't have hovering tooltip in some cases → "Tracking Protections" icon doesn't have hovering tooltip in some cases
You need to log in before you can comment on or make changes to this bug.