Closed Bug 1567545 Opened 3 years ago Closed 3 years ago

68.0b5: possible memory leak

Categories

(Thunderbird :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: thee.chicago.wolf, Unassigned)

References

Details

Attachments

(5 files)

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

I noticed my office PC slowing down and opened task manager. I'd been lightly using TB for tasks. I'm attaching a memory report in Word format with areas of warning in red.

Actual results:

TB is using 1.119GB of RAM.

Expected results:

Shouldn't be using 1.119GB of ram. 68.0b4 seemed ok. 68.0b5 is where I first noticed this issue.

Closed and restarted TB and memory usage stopped at around 314MB @ idle after about 1 minute of no use. I'm used to see around 400-500MB of memory use over the course of a work day and after not shutting TB down from Monday to Friday.

By tasks, you mean lightning tasks?
Can you reproduce?
Any detectable slowdown?

Reports of this tend to be from linux folks :)

Component: Untriaged → General

(In reply to Wayne Mery (:wsmwk) from comment #2)

By tasks, you mean lightning tasks?
Can you reproduce?
Any detectable slowdown?

Reports of this tend to be from linux folks :)

By tasks I mean just reading and replying to emails. Nothing much more than that.

Sorry, forgot to reply to your other two questions. As for repro...<shrug>. I guess just using TB regularly over the course of the day/week must be the only way to repro. The only reason I even noticed any issue was because my machine felt sluggish and things were taking a moment to show up on screen. CPU usage didn't seem high when I was looking at Task manager. Maybe 6-8% or so. As for slowdown, firing up a new email or replying to an email wasn't as quick as usual when mem usage was high. Now that I've restarted TB, it's quick as usual.

Nothing in the Word doc memory report jump out at you?

You don't think the "Global indexer causing high CPU loads under some circumstances" fix has anything to do with it?

├──1,013.85 MB (121.04%) -- maildb [?!]
│ ├────828.32 MB (98.89%) ── database(imap://---removed----)
│ ├─────49.18 MB (05.87%) ── database(news://news.mozilla.org:119/mozilla.support.thunderbird)
│ ├─────47.78 MB (05.70%) ── database(imap:// ---removed----)
│ ├─────43.10 MB (05.15%) ── database(news://news.mozilla.org:119/mozilla.support.firefox)
│ ├─────34.67 MB (04.14%) ── database(imap:// ---removed----)
│ └─────10.80 MB (01.29%) ++ (7 tiny)

Hmm, that looks more like mail databases, not the Gloda database. I don't recall any "backend" changes between b4 and b5 other than the Gloda change you quoted.

As a test, you could switch off global indexing in the advanced preferences (and even rename the message database out of the way) and see whether that makes a difference.

So, I have the situation again whereby TB is using 1GB of RAM and beginning to get sluggish. I restarted it about 10 minutes before writing this update as I was doing some testing in relation to bug 617287.

Specifically, I was testing an email received with and a simple web page I published with the below two links against TB 68.0b5 build2's response to them:

  1. news://nntp.aioe.org/comp.lang.c
  2. news:///nntp.aioe.org/comp.lang.c

When memory use was at 1GB, this instance, I had been testing link #2. But presently it didn't seem to cause the issue to happen again. When I had to restart TB ti kill the memory usage being high, TB was stuck in a state of copying my message to the Sent folder. I had to choose to not save and restart TB. When I restarted it, my send message came through immediately whereas when I was sending it and the mem usage was high, it did not immediately arrive in my inbox as it normally would. Don't know if this info is of any help but thought I'd at least write it down as I remember it happening.

Memory report on 69.0b2 appearing to show a memory leak

(In reply to Jorg K (GMT+2) from comment #6)

As a test, you could switch off global indexing in the advanced preferences (and even rename the message database out of the way) and see whether that makes a difference.

I had just had this pop up on 69.0b2 and it seems to have gotten worse. I'd forgotten to disable Global Indexer before per comment 6 so I'll do that going forward. I did a memory measurement and saved it (anonymized) as a .JSON if it's of any use.

So just wanted to report that it seems to have helped a little to disable Global Indexer. The other day I had gotten up to 800MB RAM usage but it seemed to drop and has been hovering around 425MB RAM usage. Will still keep an eye on it for the remained of this week and see if I can trigger higher RAM usage.

Well, I managed to hit 1.3GB of RAM usage just now and the CPU will spike to 25%, go quiet for about 15 seconds and do the same thing. It seems a bit sporadic. Nothing showing up in Error Console.

Anonymized memory report when TB was consuming 1.3GB, search indexer was disabled

Blocks: tb68found

What version were you using for comment 11?

Flags: needinfo?(thee.chicago.wolf)

I've also had high memory on my work PC a few times in the past two weeks. 68.x release

1.6gb memory. However, performance was not affected

(In reply to Wayne Mery (:wsmwk) from comment #13)

What version were you using for comment 11?

I think I was still on 69.0b3 or possibly 69.0b4. I feel like the 70 series has been a bit better as I haven't really hit high mem use since at least my last report(s). Could be just my imagination but I'm always aware TB is consuming crazy amounts of mem as my machines gets sluggish when it does.

Flags: needinfo?(thee.chicago.wolf)

(In reply to Wayne Mery (:wsmwk) from comment #15)

Created attachment 9097207 [details]
TB high CPU high memory.png

1.6gb memory. However, performance was not affected

Is this on a fairly current machine? I have a pretty old clunker (Intel i5 560M, 8GB ram) at work that's on an SSD at least.

Just another follow up and sorry for the noise. I was doing a lot of basic sending of emails today and for a while mem usage got up to around 800MB. Left my office for a short while and it dropped by itself to 633MB. Positive sign IMHO. I'll try and keep an eye on this whole week whilst not shutting down TB.

(In reply to Arthur K. from comment #18)

I'll try and keep an eye on this whole week whilst not shutting down TB.

How are things looking now?

(In reply to Wayne Mery (:wsmwk) from comment #19)

(In reply to Arthur K. from comment #18)

I'll try and keep an eye on this whole week whilst not shutting down TB.

How are things looking now?

This has been much better in 71.0b. I'm not noticing it anymore. Closing as WFM for now.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.