Closed Bug 1567577 Opened 2 months ago Closed Last month

Handle large texture workingsets better

Categories

(Core :: Graphics: WebRender, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox70 --- fixed

People

(Reporter: jrmuizel, Assigned: kvark)

References

(Depends on 1 open bug, Blocks 2 open bugs)

Details

Attachments

(1 file)

It looks like when we outgrow our layered texture everything goes really bad and we end up with separate textures for everything. I can reproduce this happening on mac with https://bugzilla.mozilla.org/attachment.cgi?id=9079360

Blocks: wr-perf
Priority: -- → P3
Assignee: nobody → dmalyshau
Blocks: 1566912

have texture cache to manage potentially multiple array textures of each type.

Depends on: 1555002
Pushed by dmalyshau@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/05e14a19a92c
Make WR to have multiple array textures for the shared cache r=gw
Status: NEW → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
You need to log in before you can comment on or make changes to this bug.